网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 1953|回复: 0

RIP实验脚本

[复制链接]
发表于 2007-8-20 16:49:39 | 显示全部楼层 |阅读模式
学习-RIP配置

R1#sh run
Building configuration...
Current configuration : 2322 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R1
!
!
!
!
!
!
clock timezone UTC+8 8
ip subnet-zero
no ip domain-lookup
ip host R3 3.3.3.3
ip host R2 2.2.2.2
ip host R1 1.1.1.1
!
!         
key chain ToR2
key 10
  key-string 7 02050D480809
  accept-lifetime local 22:30:00 Oct 9 2006 duration 1800
  send-lifetime local 22:30:00 Oct 9 2006 duration 1800
key 20
  key-string 7 121310191B1B0916
  accept-lifetime local 23:00:00 Oct 9 2006 infinite
  send-lifetime local 23:00:00 Oct 9 2006 infinite
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip rip send version 2
!
interface Loopback2
no ip address
!
interface Loopback3
no ip address
!
interface Loopback4
no ip address
!
interface Loopback5
no ip address
!
interface Ethernet0
ip address 10.2.123.1 255.255.255.0
!
interface Serial0
ip address 10.2.12.11 255.255.255.0 secondary
ip address 10.2.12.1 255.255.254.0
ip rip send version 2
ip rip receive version 2
ip rip authentication mode md5
ip rip authentication key-chain ToR2
encapsulation frame-relay
ip split-horizon
frame-relay map ip 10.1.12.2 102 broadcast
frame-relay map ip 10.2.12.1 102 broadcast
!
interface Serial1
no ip address
clockrate 4000000
!
interface BRI0
no ip address
shutdown
!
router rip
timers basic 5 20 20 25
passive-interface default
no passive-interface Ethernet0
no passive-interface Loopback0
no passive-interface Serial0
offset-list To_R3_Loopback in 1 Ethernet0
network 1.0.0.0
network 10.0.0.0
neighbor 10.2.123.2
maximum-paths 2
distribute-list eth_router out Ethernet0
distribute-list OUSHU_from_R3 in Ethernet0
distribute-list prefix To_loop0 out Loopback0
distribute-list JISHU_from_R3 in Serial0
!
ip classless
no ip http server
!
!
ip prefix-list To_loop0 seq 5 permit 150.100.0.0/16
!
ip access-list standard JISHU_from_R3
permit 202.96.1.0 0.0.254.255
deny   any
ip access-list standard OUSHU_from_R3
permit 202.96.0.0 0.0.254.255
deny   any
ip access-list standard To_R3_Loopback
permit 3.0.0.0
ip access-list standard eth_router
permit 1.0.0.0
deny   any
!
!
line con 0
exec-timeout 0 0
password 7 1210111613
logging synchronous
login
line aux 0
line vty 0 4
privilege level 15
no login
!
ntp clock-period 17180097
ntp server 2.2.2.2


R2#sh run
Building configuration...
Current configuration : 2495 bytes
!
! Last configuration change at 12:47:06 UTC+8 Mon Mar 1 1993
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R2
!
!
!
!
!
!
clock timezone UTC+8 8
ip subnet-zero
no ip domain-lookup
ip host R3 3.3.3.3
ip host R2 2.2.2.2
ip host R1 1.1.1.1
!
frame-relay switching
!
key chain ToR1
key 10
  key-string 7 00071A150754
  accept-lifetime local 22:30:00 Oct 9 2006 duration 1800
  send-lifetime local 22:30:00 Oct 9 2006 duration 1800
key 20
  key-string 7 141D070505142F39
  accept-lifetime local 23:00:00 Oct 9 2006 infinite
  send-lifetime local 23:00:00 Oct 9 2006 infinite
key chain ToR3
key 10
  key-string 7 05011301285C4B1B
  accept-lifetime local 22:30:00 Oct 9 2006 duration 1800
  send-lifetime local 22:30:00 Oct 9 2006 duration 1800
key 20
  key-string 7 110A1016141D
  accept-lifetime local 23:00:00 Oct 9 2006 infinite
  send-lifetime local 23:00:00 Oct 9 2006 infinite
!
!         
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
ip address 150.100.2.2 255.255.255.0
!
interface Ethernet0
ip address 10.2.123.2 255.255.255.0
!
interface Serial0
ip address 10.2.12.2 255.255.255.0
ip rip send version 2
ip rip receive version 2
ip rip authentication mode md5
ip rip authentication key-chain ToR1
encapsulation frame-relay
ip split-horizon
ip summary-address rip 150.100.0.0 255.255.248.0
clockrate 4000000
frame-relay map ip 10.2.12.2 102 broadcast
frame-relay interface-dlci 102
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface Serial1
ip address 150.100.4.2 255.255.255.0 secondary
ip address 10.2.23.2 255.255.255.0
ip rip triggered
ip rip v2-broadcast
ip rip send version 2
ip rip receive version 2
ip rip authentication mode md5
ip rip authentication key-chain ToR3
clockrate 4000000
!
interface BRI0
no ip address
shutdown
!
router rip
timers basic 5 20 0 25
passive-interface default
no passive-interface Ethernet0
no passive-interface Serial0
no passive-interface Serial1
network 2.0.0.0
network 10.0.0.0
network 150.100.0.0
distribute-list eth_router out Ethernet0
no auto-summary
!
ip classless
no ip http server
!
!
ip access-list standard eth_router
permit 2.0.0.0
deny   any
!
!
line con 0
exec-timeout 0 0
password 7 04521F070E
logging synchronous
login
line aux 0
line vty 0 4
privilege level 15
no login
!
ntp source Loopback0
ntp master 1
ntp peer 1.1.1.1
ntp peer 3.3.3.3
end


R3#sh run
Building configuration...
Current configuration : 2119 bytes
!
! Last configuration change at 12:49:43 UTC+8 Mon Mar 1 1993
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname R3
!
!
!
!
!
!
clock timezone UTC+8 8
ip subnet-zero
no ip domain-lookup
ip host R3 3.3.3.3
ip host R2 2.2.2.2
ip host R1 1.1.1.1
!
!
key chain ToR2
key 10
  key-string 7 05011301285C4B1B
  accept-lifetime local 22:30:00 Oct 9 2006 duration 1800
  send-lifetime local 22:30:00 Oct 9 2006 duration 1800
key 20
  key-string 7 0822455D0A16
  accept-lifetime local 23:00:00 Oct 9 2006 infinite
  send-lifetime local 23:00:00 Oct 9 2006 infinite
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 150.100.3.3 255.255.255.0
!
interface Loopback2
ip address 202.96.2.2 255.255.255.0
!         
interface Loopback3
ip address 202.96.3.3 255.255.255.0
!
interface Loopback4
ip address 202.96.4.4 255.255.255.0
!
interface Loopback5
ip address 202.96.5.5 255.255.255.0
!
interface Ethernet0
ip address 10.2.123.3 255.255.255.0
!
interface Serial0
no ip address
clockrate 4000000
!
interface Serial1
ip address 150.100.4.3 255.255.255.0 secondary
ip address 10.2.23.3 255.255.255.0
ip rip triggered
ip rip v2-broadcast
ip rip send version 2
ip rip receive version 2
ip rip authentication mode md5
ip rip authentication key-chain ToR2
!
interface BRI0
no ip address
shutdown
!
router rip
timers basic 5 20 0 25
passive-interface default
no passive-interface Ethernet0
no passive-interface Serial1
network 3.0.0.0
network 10.0.0.0
network 150.100.0.0
network 202.96.2.0
network 202.96.3.0
network 202.96.4.0
network 202.96.5.0
distribute-list eth_router out Ethernet0
no auto-summary
!
ip classless
no ip http server
!
!
ip access-list standard eth_router
permit 3.0.0.0
permit 202.96.2.0
permit 202.96.3.0
permit 202.96.4.0
permit 202.96.5.0
deny   any
!
!
line con 0
exec-timeout 0 0
password 7 0502120E20
logging synchronous
login
line aux 0
line vty 0 4
privilege level 15
no login
!
ntp clock-period 17180226
ntp server 2.2.2.2
end

end
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-10-23 13:33 , Processed in 0.109200 second(s), 22 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表