网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 1712|回复: 0

ADSL与NAT

[复制链接]
发表于 2007-8-29 20:51:28 | 显示全部楼层 |阅读模式
电信最近力推的ADSL是一种性能价格比较好的Internet接入方式,适用于只需访问Internet,不需要对外提供服务(如 WWW, Mail等)的场合。ADSL最常见的应用方式是用一台安装了PPPoE客户端软件的PC来拔号作代理服务器,让多台主机同时访问Internet。有的时候该PC的任务也可以用路由器来完成,最低档的2514路由器就能胜任,只要路由器有两个以太端网口即可。当然,还需要有适当的IOS软件,同时支持PPPoE Client和NAT两个特性、需求最低的IOS是“REMOTE ACCESS SERVER”特性集。以2621为例,运行该IOS只需32M内存、8M Flash,文件名为:c2600-c-mz.122-4.T1.bin ,这就是下面配置的运行环境。
  实际运行的配置:
  version 12.2
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname 2621
  !
  enable secret 5 $1$LJV3$jqSDKFMSZiQBAjlnN/
  !
  ip subnet-zero
  ip name-server 202.xxx.xxx.xxx
  !
  vpdn enable
  !
  vpdn-group PPPoE
  request-dialin
  protocol pppoe
  !
  interface FastEthernet0/0
  ip address 10.1.1.1 255.255.255.0
  ip nat inside
  duplex auto
  speed auto
  !
  interface FastEthernet0/1
  no ip address
  speed 10
  half-duplex
  pppoe enable
  pppoe-client dial-pool-number 1
  !
  interface Dialer1
  mtu 1492
  ip address negotiated
  ip nat outside
  encapsulation ppp
   no ip mroute-cache
  dialer pool 1
  dialer-group 1
  no cdp enable
  ppp authentication pap callin
  ppp pap sent-username abc123@163 password 7 **********
  !
  ip nat inside source list 1 interface Dialer1 overload
  ip classless
  ip route 0.0.0.0 0.0.0.0 Dialer1 permanent
  no ip http server
  ip pim bidir-enable
  !
  access-list 1 permit any
  dialer-list 1 protocol ip permit
  !
  line con 0
  line aux 0
  line vty 0 4
  password *****
  login
  !
  end
  在下行速度为2M的ADSL线路上,F0/0上接只一台PC,用蚂蚁下载测试时,峰值速度竟超过300K,不知道是不是蚂蚁有点夸大了。:-) 值得注意的是有的地区需要用chap认证方式,这时相应的指令为:
  ppp authentication chap callin
  ppp chap hostname abc123@163
  ppp chap password **********
  相关调试命令:
  
  
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-16 07:18 , Processed in 0.109200 second(s), 22 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表