网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 1824|回复: 0

EIGRP实验配置过程详解

[复制链接]
发表于 2007-8-20 16:18:38 | 显示全部楼层 |阅读模式
EIGRP实验配置过程详解
2007-08-05 16:15

实验环境说明:
1.将路由器R1的Fa0/0端口配置ip:172.16.0.1/24;S1/2端口配置ip:192.168.1.1/24
2.将路由器R2的Fa0/0端口配置ip:192.168.3.2/24;S1/2端口配置ip:192.168.1.2/24
3.将路由器R3 的Fa0/0端口配置ip:172.16.0.3/24
4.将交换机SW1分别划分两个VLAN2、VLAN3,将端口Fa1/13、Fa1/15划入VLAN2,将端口Fa1/14划入VLAN3  
实验结果:要求路由器间两两可以互相通信
配置过程详解:
交换机SW1的配置清单:

1.首先禁用错误命令当域名解析和关闭超时退出控制台:
SW1(config)#no ip domain-loo
SW1(config)#line con 0
SW1(config-line)#no exec-t
SW1(config-line)#exit
2.划分VLAN:
SW1#vlan data
SW1(vlan)#vlan 2
SW1(vlan)#vlan 3
SW1(vlan)#exit
3.将Fa1/13端口设为全双工模式,并划入VLAN2:
SW1(config)#int fa1/13
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#sw mod acc
SW1(config-if)#sw acc vlan 2
SW1(config-if)#exit
4.将Fa1/15端口设为全双工模式,并划入VLAN2:
SW1(config)#int fa1/15
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#sw mod acc
SW1(config-if)#sw acc vlan 2
SW1(config-if)#exit   
5.将Fa1/14端口设为全双工模式,并划入VLAN3:
SW1(config)#int fa1/14
SW1(config-if)#speed 100
SW1(config-if)#duplex full
SW1(config-if)#sw mod acc
SW1(config-if)#sw acc vlan 3
SW1(config-if)#exit  
路由器R1的配置清单:

1.首先禁用错误命令当域名解析和禁用超时退出控制台:
R1(config)#no ip domain-loo
R1(config)#line con 0
R1(config-line)#no exec-t
R1(config-line)#exit
2.将Fa0/0端口设为全双工模式并配置ip:
R1(config)#int fa0/0
R1(config-if)#speed 100
R1(config-if)#duplex full
R1(config-if)#ip add 172.16.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
3.为S1/2端口配置ip:
R1(config)#int s1/2
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
4.在路由器R1上配置EIGRP:
R1(config)#router eigrp 100
R1(config-router)#no auto-summary
R1(config-router)#network 172.16.0.1 0.0.0.0
R1(config-router)#network 192.168.1.1 0.0.0.255
R1(config-router)#exit
R1(config)#exit
路由器R2的配置清单:

1.首先禁用错误命令当域名解析和禁用超时退出控制台:
R2(config)#no ip domain-loo
R2(config)#line con 0
R2(config-line)#no exec-t
R2(config-line)#exit
2.将Fa0/0端口设为全双工模式并配置ip:
R2(config)#int fa0/0
R2(config-if)#speed 100
R2(config-if)#duplex full
R2(config-if)#ip add 192.168.3.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
3.为S1/2端口配置ip:
R2(config)#int s1/2
R2(config-if)#ip add 192.168.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
4.在路由器R2上配置EIGRP:
R2(config)#router eigrp 100
R2(config-router)#network 192.168.3.0 0.0.0.255
R2(config-router)#network 192.168.1.0 0.0.0.255
R2(config-router)#exit
R2(config)#exit
路由器R3的配置清单:

1.首先禁用错误命令当域名解析和禁用超时退出控制台:
R3(config)#no ip domain-loo
R3(config)#line con 0
R3(config-line)#no exec-t
R3(config-line)#exit
2.将Fa0/0端口设为全双工模式并配置ip:
R3(config)#int fa0/0
R3(config-if)#speed 100
R3(config-if)#duplex full
R3(config-if)#ip add 172.16.0.3 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
3.在路由器R3上配置EIGRP:
R3(config)#router eigrp 100
R3(config-router)#no auto-summary
R3(config-router)#network 172.16.0.3 0.0.0.0
R3(config-router)#exit
R3(config)#exit
验证EIGRP配置:
查看每台路由器的邻居表:#show ip eigrp nei
R1的邻居表:
R1#show ip eigrp nei
IP-EIGRP neighbors for process 100
H    Address                  Interface        Hold Uptime    SRTT    RTO   Q   Seq
                                             (sec)          (ms)        Cnt Num
1    172.16.0.3               Fa0/0              11 00:00:48   168   1008   0   4
0    192.168.1.2              Se1/2              14 00:25:23   244   1464   0   3
R2的邻居表:
R2#show ip eigrp nei
IP-EIGRP neighbors for process 100
H    Address                  Interface        Hold Uptime    SRTT    RTO   Q   Seq
                                             (sec)          (ms)        Cnt Num
0    192.168.1.1              Se1/2              14 00:28:34   195   1755   0   5
R3的邻居表:
R3r#show ip eigrp nei
IP-EIGRP neighbors for process 100
H    Address                  Interface        Hold Uptime    SRTT    RTO   Q   Seq
                                             (sec)          (ms)        Cnt Num
0    172.16.0.1               Fa0/0              12 00:02:07   134    804   0   8
实验的最终结果是每台路由器之间都可以ping通其他的路由器,实验过程到此结束。


您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-10-23 13:18 , Processed in 0.124800 second(s), 22 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表