网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 2467|回复: 8

网络学院路由交换第2卷v3.0《实验指导书》教师参考

[复制链接]
发表于 2013-10-20 16:34:19 | 显示全部楼层 |阅读模式
VLAN
*基于MAC地址的VLAN配置
实验组网如图1-1所示,本实验任务通过在交换机上配置MAC地址与VLAN关联,让交换机能够按照设定的MAC地址为数据帧分配VLAN标签(Tag),从而使处于相同VLAN内的PC可以互通。用户物理位置移动时,即使更换了交换机连接PC的端口,PC所属的VLAN也不会改变。通过本实验,读者能够学会交换机上基于MAC地址的VLAN配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
观察交换机初始MAC地址表
 按照实验组网图1-1所示连接所有PC和交换机,在交换机SWA和SWB上执行 display mac-address命令查看SWA和SWB初始的MAC地址表,然后根据此输出结果补充表1-2内容:
PC的MAC地址
设备        VLAN ID        MAC
PCA        1        aaaa-aaaa-aaaa
PCB        1        bbbb-bbbb-bbbb
PCC        1        cccc-cccc-cccc
PCD        1        dddd-dddd-dddd

配置基于MAC地址的VLAN
首先配置SWA。
在SWA上创建VLAN10和VLAN20,将PCA的MAC地址和VLAN10关联,将PCB的MAC地址和VLAN20关联。请在下面的空格中写出完整的配置命令:
[SWA]vlan 10
[SWA]vlan 20
[SWA]mac-vlan mac-address AAAA-AAAA-AAAA vlan 10
[SWA]mac-vlan mac-address BBBB-BBBB-BBBB vlan 20
在SWA上执行display mac-vlan all命令查看交换机上MAC-VLAN表的所有表项,然后根据输出结果补充表1-3内容:
display mac-vlan all命令显示相关信息表
MAC ADDR        MASK        VLAN ID        PRIO        STATE
aaaa-aaaa-aaaa        ffff-ffff-ffff        10        0        S
bbbb-bbbb-bbbb        ffff-ffff-ffff        20        0        S
从表1-3中可以看到,display mac-vlan all命令显示相关信息表对应的RPIO表示:
用户配置的MAC地址所对应的802.1P优先级。
在SWA上设置端口GigabitEthernet1/0/1和GigabitEthernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上开启基于MAC地址划分VLAN的功能。请在下面的空格中填写完整的配置命令:
[SWA]interface GigabitEthernet 1/0/1
[SWA-GigabitEthernet1/0/1]port link-type hybrid
[SWA-GigabitEthernet1/0/1]port hybrid vlan 10 20 untagged
[SWA-GigabitEthernet1/0/1]mac-vlan enable
[SWA]interface GigabitEthernet 1/0/2
[SWA-GigabitEthernet1/0/2]port link-type hybrid      
[SWA-GigabitEthernet1/0/2]port hybrid vlan 10 20 untagged
[SWA-GigabitEthernet1/0/2]mac-vlan enable
在SWA上配置端口GigabitEthernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWA]interface GigabitEthernet 1/0/24
[SWA-GigabitEthernet1/0/24]port link-type trunk
[SWA-GigabitEthernet1/0/24]port trunk permit vlan 10 20
然后配置SWB。
在SWB上创建VLAN10和VLAN20,将PCC的MAC地址和VLAN10关联,将PCD的MAC地址和VLAN20关联。请在下面的空格中写出完整的配置命令:
[SWB]vlan 10
[SWB]vlan 20
[SWB]mac-vlan mac-address CCCC-CCCC-CCCC vlan 10
[SWB]mac-vlan mac-address DDDD-DDDD-DDDD vlan 20
在SWB上执行display mac-vlan all命令查看交换机上MAC-VLAN表的所有表项,然后根据输出结果补充表1-4内容:
display mac-vlan all命令显示相关信息表
MAC ADDR        MASK        VLAN ID        PRIO        STATE
cccc-cccc-cccc        ffff-ffff-ffff        10        0        S
dddd-dddd-dddd        ffff-ffff-ffff        20        0        S
从表1-4中可以看到,display mac-vlan all命令显示相关信息表对应的STATE值为S表示:
该表项是通过用户静态配置生成的。
在SWB上设置端口GigabitEthernet1/0/1和GigabitEthernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上开启基于MAC地址划分VLAN的功能。请在下面的空格中写出完整的配置命令:
[SWB]interface GigabitEthernet 1/0/1
[SWB-GigabitEthernet1/0/1]port link-type hybrid
[SWB-GigabitEthernet1/0/1]port hybrid vlan 10 20 untagged
[SWB-GigabitEthernet1/0/1]mac-vlan enable
[SWB]interface GigabitEthernet 1/0/2
[SWB-GigabitEthernet1/0/2]port link-type hybrid     
[SWB-GigabitEthernet1/0/2]port hybrid vlan 10 20 untagged
[SWB-GigabitEthernet1/0/2]mac-vlan enable
在SWB上配置端口GigabitEthernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWB]interface GigabitEthernet 1/0/24
[SWB-GigabitEthernet1/0/24]port link-type trunk
[SWB-GigabitEthernet1/0/24]port trunk permit vlan 10 20
 配置完成后,在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-5内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/1        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/2        AGING
 在SWB上执行display mac-address命令查看SWB的MAC地址表,然后根据此输出结果补充表1-6内容:
SWB的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/24        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/1        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/2        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/24        AGING
测试VLAN内的互通
在PC上配置IP地址,通过Ping命令来测试处于相同VLAN内的PC能否互通。
IP地址列表
设备名称        IP地址        网关
PCA        192.168.1.1        --
PCB        192.168.2.1        --
PCC        192.168.1.2        --
PCD        192.168.2.2        --
按表1-7所示在PC上配置IP地址。
配置完成后,在PCA和PCB上用Ping命令来测试到其它PC的互通性。其结果应该是PCA与PCC能(能/不能)互通,PCB和PCD能(能/不能)互通。
更换SWA连接PCA的端口
把SWA连接PCA的端口由GigabitEthernet1/0/1更换为GigabitEthernet1/0/5,设置GigabitEthernet1/0/5为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上开启基于MAC地址划分VLAN的功能。请在下面的空格中填写完整的配置命令:
[SWA]interface GigabitEthernet 1/0/5
[SWA-GigabitEthernet1/0/5]port link-type hybrid
[SWA-GigabitEthernet1/0/5]port hybrid vlan 10 20 untagged
[SWA-GigabitEthernet1/0/5]mac-vlan enable
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-8内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/5        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/2        AGING
在PCA上用Ping命令来测试与PCC能否互通,其结果应该是 能 (能/不能)互通。
说明基于MAC地址划分VLAN的方法其最大优点就是当用户物理位置移动时,即从交换机的一个端口换到另外一个端口或其它交换机的端口时,VLAN不用重新配置。
 楼主| 发表于 2013-10-20 16:34:56 | 显示全部楼层
基于协议的VLAN配置
实验组网如图1-2所示,本实验任务通过在交换机上配置IPv4和IPv6协议与相应VLAN关联,让交换机能够按照设定的协议为数据帧分配VLAN标签(Tag),使网络中基于IPv4地址和IPv6地址的主机能分别进行通信。用户物理位置移动时,即使更换了交换机连接PC的端口,PC所属的VLAN也不会改变。通过本实验,读者能够学会交换机上基于协议的VLAN配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置基于协议的VLAN
首先配置SWA。
在SWA上创建VLAN10和VLAN20,分别匹配IPv4和IPv6协议模板。请在下面的空格中写出完整的配置命令:
[SWA]vlan 10
[SWA-vlan10]protocol-vlan ipv4(匹配IPv4协议模板)
[SWA]vlan 20
[SWA-vlan20]protocol-vlan ipv6(匹配IPv6协议模板)
在SWA上执行display protocol-vlan all命令查看当前所有协议VLAN的协议信息及协议的索引。然后根据输出结果补充表1-9内容:
display protocol-vlan all命令显示相关信息表
VLAN ID        Protocol Index        Protocol Type
10        0        ipv4
20        0        ipv6
在SWA上设置端口Ethernet1/0/1和Ethernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且与VLAN10的协议模板0和VLAN20的协议模板0绑定。请在下面的空格中填写完整的配置命令:
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1]port link-type hybrid
[SWA-Ethernet1/0/1]port hybrid vlan 10 20 untagged
[SWA-Ethernet1/0/1]port hybrid protocol-vlan vlan 10 0(和VLAN10的协议模板0绑定)
[SWA-Ethernet1/0/1]port hybrid protocol-vlan vlan 20 0(和VLAN20的协议模板0绑定)
[SWA]interface Ethernet 1/0/2           
[SWA-Ethernet1/0/2]port link-type hybrid              
[SWA-Ethernet1/0/2]port hybrid vlan 10 20 untagged
[SWA-Ethernet1/0/2]port hybrid protocol-vlan vlan 10 0(和VLAN10的协议模板0绑定)
[SWA-Ethernet1/0/2]port hybrid protocol-vlan vlan 20 0(和VLAN20的协议模板0绑定)
在SWA上配置端口Ethernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]port link-type trunk
[SWA-Ethernet1/0/24]port trunk permit vlan 10 20
然后配置SWB。
在SWB上创建VLAN10和VLAN20,分别匹配IPv4和IPv6协议模板。请在下面的空格中写出完整的配置命令:
[SWB]vlan 10
[SWB-vlan10]protocol-vlan ipv4(匹配IPv4协议模板)
[SWB]vlan 20
[SWB-vlan20]protocol-vlan ipv6(匹配IPv6协议模板)
在SWB上执行display protocol-vlan all命令查看当前所有协议VLAN的协议信息及协议的索引。然后根据输出结果补充表1-10内容:
display protocol-vlan all命令显示相关信息表
VLAN ID        Protocol Index        Protocol Type
10        0        ipv4
20        0        ipv6
在SWB上设置端口Ethernet1/0/1和Ethernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且与VLAN10的协议模板0和VLAN20的协议模板0绑定。请在下面的空格中填写完整的配置命令:
[SWB]interface Ethernet 1/0/1
[SWB-Ethernet1/0/1]port link-type hybrid
[SWB-Ethernet1/0/1]port hybrid vlan 10 20 untagged
[SWB-Ethernet1/0/1]port hybrid protocol-vlan vlan 10 0(和VLAN10的协议模板0绑定)
[SWB-Ethernet1/0/1]port hybrid protocol-vlan vlan 20 0(和VLAN20的协议模板0绑定)
[SWB]interface Ethernet 1/0/2           
[SWB-Ethernet1/0/2]port link-type hybrid              
[SWB-Ethernet1/0/2]port hybrid vlan 10 20 untagged   
[SWB-Ethernet1/0/2]port hybrid protocol-vlan vlan 10 0(和VLAN10的协议模板0绑定)
[SWB-Ethernet1/0/2]port hybrid protocol-vlan vlan 20 0(和VLAN20的协议模板0绑定)
在SWB上配置端口Ethernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWB]interface Ethernet 1/0/24
[SWB-Ethernet1/0/24]port link-type trunk
[SWB-Ethernet1/0/24]port trunk permit vlan 10 20
测试VLAN内的互通
在PC上配置IP地址,通过Ping命令来测试处于相同VLAN内的PC能否互通。
表1-11列出Windows XP常用的IPv6配置命令:
Windows XP常用IPv6配置命令
命令        解释
C:\>ipv6 install        安装IPv6协议栈
C:\>ipv6 uninstall           卸载IPv6协议栈
C:\>ipv6 if          查看所有接口详细信息
C:\>ipv6 if  6          查看6号接口详细信息
C:\>ipv6 adu 6/2001::1        为6号接口配置IP地址
C:\>ipv6 adu 6/2000::1 life 0        删除接口6的IP地址
C:\>ipv6 rtu ::/0 6/2001::2        为接口6配置路由
C:\>ipv6 rtu ::/0 6/2001::2 life 0        删除接口的路由
C:\>ipv6 ifd 5        删除接口5
C:\>ipv6 reset        恢复缺省配置,删除其它的接口,及所有的手工IP,及路由表项

IP地址列表
设备名称        IP地址        网关
PCA        192.168.1.1        --
PCB        2001::1        --
PCC        192.168.1.2        --
PCD        2001::2        --
按表1-12所示在PC上配置IP地址,下面列出了PCB和PCD配置IPv6地址过程。
PCB配置IPv6:
C:\Documents and Settings\Administrator>ipv6 install
Installing...
Succeeded.
C:\Documents and Settings\Administrator>ipv6 if
Interface 6: Ethernet: 本地连接 8
  Guid {B93B60EA-C85B-4B1D-9B00-C811104C2863}
  zones: link 6 site 2
  uses Neighbor Discovery
  uses Router Discovery
  link-layer address: 00-16-ec-71-ea-50
    preferred link-local fe80::216:ecff:fe71:ea50, life infinite
  
C:\Documents and Settings\Administrator>ipv6 adu 6/2001::1

C:\Documents and Settings\Administrator>ipv6 if 6
Interface 6: Ethernet: 本地连接 8
  Guid {B93B60EA-C85B-4B1D-9B00-C811104C2863}
  zones: link 6 site 2
  uses Neighbor Discovery
  uses Router Discovery
  link-layer address: 00-16-ec-71-ea-50
    preferred global 2001::1, life infinite (manual)
    preferred link-local fe80::216:ecff:fe71:ea50, life infinite

PCD配置IPv6:
C:\Documents and Settings\Administrator>ipv6 install
Installing...
Succeeded.

C:\Documents and Settings\Administrator>ipv6 if
Interface 6: Ethernet: 本地连接 7
  Guid {BF140E09-C31A-4854-A5EC-CA04E922121C}
  zones: link 6 site 2
  uses Neighbor Discovery
  uses Router Discovery
  link-layer address: 00-13-46-ec-31-7d
    preferred link-local fe80::213:46ff:feec:317d, life infinite

C:\Documents and Settings\Administrator>ipv6 adu 6/2001::2

C:\Documents and Settings\Administrator>ipv6 if 6
Interface 6: Ethernet: 本地连接 7
  Guid {BF140E09-C31A-4854-A5EC-CA04E922121C}
  zones: link 6 site 2
  uses Neighbor Discovery
  uses Router Discovery
  link-layer address: 00-13-46-ec-31-7d
    preferred global 2001::2, life infinite (manual)
在PCB上用Ping命令来测试与PCD能否互通,其结果应该是 能 (能/不能)互通。
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-13内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/1        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        10        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        10        Learned        GigabitEthernet1/0/2        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/2        AGING
从以上信息可以看出,PCB和PCD的MAC地址在VLAN20内学习到了。因为PCB和PCD缺省启用IPv4协议,所以PCB和PCD的MAC地址也会学习到VLAN10内,这个不是我们关注的焦点,我们关注的焦点是交换机根据PCB和PCD的IPv6地址匹配到了IPv6协议模板,给数据帧分配了VLAN20的标签(Tag)。
更换SWA连接PCB的端口
把SWA连接PCB的端口由Ethernet1/0/2更换为Ethernet1/0/6,设置Ethernet1/0/6为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且与VLAN10的协议模板0和VLAN20的协议模板0绑定。请在下面的空格中填写完整的配置命令:
[SWA]interface Ethernet 1/0/6
[SWA-Ethernet1/0/6] port link-type hybrid
[SWA-Ethernet1/0/6] port hybrid vlan 1 10 20 untagged
[SWA-Ethernet1/0/6] port hybrid protocol-vlan vlan 10 0(和VLAN10的协议模板0绑定)
[SWA-Ethernet1/0/6] port hybrid protocol-vlan vlan 20 0(和VLAN20的协议模板0绑定)
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-14内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/1        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        10        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        10        Learned        GigabitEthernet1/0/6        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/6        AGING
在PCB上用Ping命令来测试与PCD能否互通,其结果应该是能(能/不能)互通。
说明基于协议划分VLAN和基于MAC地址划分VLAN优点一样。
 楼主| 发表于 2013-10-20 16:37:02 | 显示全部楼层
基于IP子网的VLAN配置
实验组网如图1-2所示,本实验任务通过在交换机上配置两个IP子网与相应VLAN关联,让交换机能够按照设定的IP子网为数据帧分配VLAN标签(Tag),从而使处于相同VLAN内的PC可以互通。用户物理位置移动时,即使更换了交换机连接PC的端口,PC所属的VLAN也不会改变。通过本实验,读者能够学会交换机上基于IP子网的VLAN配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置基于IP子网的VLAN
首先配置SWA。
在SWA上创建VLAN10和VLAN20,分别与IP网段10.10.10.0/24和IP网段20.20.20.0/24关联。请在下面的空格中写出完整的配置命令:
[SWA]vlan 10
[SWA-vlan10]ip-subnet-vlan ip 10.10.10.0 255.255.255.0
[SWA]vlan 20
[SWA-vlan20]ip-subnet-vlan ip 20.20.20.0 255.255.255.0
在SWA上执行display ip-subnet-vlan vlan all命令查看VLAN上配置的IP子网信息及IP子网的索引。然后根据输出结果补充表1-15内容:
display ip-subnet-vlan vlan all命令显示相关信息表
VLAN ID        Subnet Index        IP Address        Subnet Mask
10        0        10.10.10.0        255.255.255.0
20        0        20.20.20.0        255.255.255.0

在SWA上设置端口Ethernet1/0/1和Ethernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上与VLAN10和VLAN20的子网进行关联。请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1]port link-type hybrid
[SWA-Ethernet1/0/1]port hybrid vlan 10 20 untagged   
[SWA-Ethernet1/0/1]port hybrid ip-subnet-vlan vlan 10(将端口与IP子网VLAN10关联)
[SWA-Ethernet1/0/1]port hybrid ip-subnet-vlan vlan 20(将端口与IP子网VLAN20关联)
[SWA]interface Ethernet 1/0/2         
[SWA-Ethernet1/0/2]port link-type hybrid            
[SWA-Ethernet1/0/2]port hybrid vlan 10 20 untagged   
[SWA-Ethernet1/0/2]port hybrid ip-subnet-vlan vlan 10(将端口与IP子网VLAN10关联)
[SWA-Ethernet1/0/2]port hybrid ip-subnet-vlan vlan 20(将端口与IP子网VLAN20关联)
在SWA上配置端口GigabitEthernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]port link-type trunk
[SWA-Ethernet1/0/24]port trunk permit vlan 10 20
然后配置SWB。
在SWB上创建VLAN10和VLAN20,分别与IP网段10.10.10.0/24和IP网段20.20.20.0/24关联。请在下面的空格中写出完整的配置命令:
[SWB]vlan 10
[SWB-vlan10]ip-subnet-vlan ip 10.10.10.0 255.255.255.0
[SWB]vlan 20
[SWB-vlan20]ip-subnet-vlan ip 20.20.20.0 255.255.255.0
在SWB上执行display ip-subnet-vlan vlan all命令查看VLAN上配置的IP子网信息及IP子网的索引。然后根据输出结果补充表1-16内容:
display ip-subnet-vlan vlan all命令显示相关信息表
VLAN ID        Subnet Index        IP Address        Subnet Mask
10        0        10.10.10.0        255.255.255.0
20        0        20.20.20.0        255.255.255.0
在SWB上设置端口Ethernet1/0/1和Ethernet1/0/2为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上与VLAN10和VLAN20的子网进行关联。请在下面的空格中写出完整的配置命令:
[SWB]interface Ethernet 1/0/1
[SWB-Ethernet1/0/1]port link-type hybrid
[SWB-Ethernet1/0/1]port hybrid vlan 10 20 untagged   
[SWB-Ethernet1/0/1]port hybrid ip-subnet-vlan vlan 10(将端口与IP子网VLAN10关联)
[SWB-Ethernet1/0/1]port hybrid ip-subnet-vlan vlan 20(将端口与IP子网VLAN20关联)
[SWB]interface Ethernet 1/0/2         
[SWB-Ethernet1/0/2]port link-type hybrid            
[SWB-Ethernet1/0/2]port hybrid vlan 10 20 untagged   
[SWB-Ethernet1/0/2]port hybrid ip-subnet-vlan vlan 10(将端口与IP子网VLAN10关联)
[SWB-Ethernet1/0/2]port hybrid ip-subnet-vlan vlan 20(将端口与IP子网VLAN20关联)
在SWB上配置端口Ethernet1/0/24为Trunk链路端口,并且允许VLAN10和VLAN20通过。请在下面的空格中写出完整的配置命令:
[SWB]interface Ethernet 1/0/24
[SWB-Ethernet1/0/24]port link-type trunk
[SWB-Ethernet1/0/24]port trunk permit vlan 10 20
测试VLAN内的互通
在PC上配置IP地址,通过Ping命令来测试处于相同VLAN内的PC能否互通。
IP地址列表
设备名称        IP地址        网关
PCA        10.10.10.1        --
PCB        20.20.20.1        --
PCC        10.10.10.2        --
PCD        20.20.20.2        --
按表1-17所示在PC上配置IP地址,
在PCA上用Ping命令来测试与PCC能否互通,其结果应该是能(能/不能)互通。
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-18内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/1        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/2        AGING
 在SWB上执行display mac-address命令查看SWB的MAC地址表,然后根据此输出结果补充表1-19内容:
SWB的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/24        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/1        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/2        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/24        AGING
从以上信息可以看出,SWA和SWB的Ethernet1/0/1端口学习到的MAC地址都在VLAN10内,而PCA和PCC分别接在SWA和SWB的Ethernet1/0/1端口,且它们的IP地址都是10.10.10.0/24网段,从而可以推断,交换机把10.10.10.0/24网段的IP地址划分到了VLAN10。PCB和PCD同理,不再赘述。
更换SWA连接PCA的端口
把SWA连接PCA的端口由Ethernet1/0/1更换为Ethernet1/0/6,设置端口Ethernet1/0/6为Hybrid链路端口,允许VLAN10和VLAN20不带标签(Untagged)通过,并且在端口上与VLAN10和VLAN20的子网进行关联。请在下面的空格中填写完整的配置命令:
[SWA]interface Ethernet 1/0/6
[SWA-Ethernet1/0/6]port link-type hybrid
[SWA-Ethernet1/0/6]port hybrid vlan 10 20 untagged
[SWA-Ethernet1/0/6]port hybrid ip-subnet-vlan vlan 10(将端口与IP子网VLAN10关联)
[SWA-Ethernet1/0/6]port hybrid ip-subnet-vlan vlan 20(将端口与IP子网VLAN20关联)
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表1-20内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/6        AGING
cccc-cccc-cccc        10        Learned        GigabitEthernet1/0/24        AGING
dddd-dddd-dddd        20        Learned        GigabitEthernet1/0/24        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/2        AGING
在PCA上用Ping命令来测试与PCC能否互通,其结果应该是能(能/不能)互通。
说明基于IP子网划分VLAN和基于MAC地址划分VLAN优点一样。
 楼主| 发表于 2013-10-21 14:49:43 | 显示全部楼层
GVRP
GVRP基本配置
实验组网如图2-1所示,本实验任务通过在交换机相应端口上开启GVRP功能,使得PCA可以访问PCC,再通过在交换机上查看相关VLAN信息,分析VLAN动态注册过程。通过本实验,使读者能够很好的掌握GVRP的基本原理和配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置基于端口的VLAN
首先配置SWA。
在SWA上创建VLAN10,将PCA所连接的端口Ethernet1/0/1添加到VLAN10中;在SWA上配置端口Ethernet1/0/24为Trunk链路端口,并允许所有的VLAN通过。请在下面的空格中写出完整的配置命令:
[SWA]vlan 10
[SWA-vlan10]port Ethernet 1/0/1
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]port link-type trunk
[SWA-Ethernet1/0/24]port trunk permit vlan all
然后配置SWB。
在SWB上配置端口Ethernet1/0/23和Ethernet1/0/24为Trunk链路端口,并允许所有的VLAN通过。请在下面的空格中写出完整的配置命令:
[SWB]interface Ethernet 1/0/23
[SWB-Ethernet1/0/23]port link-type trunk
[SWB-Ethernet1/0/23]port trunk permit vlan all
[SWB]interface Ethernet 1/0/24  
[SWB-Ethernet1/0/24]port link-type trunk      
[SWB-Ethernet1/0/24]port trunk permit vlan all
最后配置SWC。
在SWC上创建VLAN10,将PCC所连接的端口Ethernet1/0/1添加到VLAN10中;在SWC上配置端口Ethernet1/0/24为Trunk链路端口,并允许所有的VLAN通过。请在下面的空格中写出完整的配置命令:
[SWC]vlan 10
[SWC-vlan10]port Ethernet 1/0/1
[SWC]interface Ethernet 1/0/24
[SWC-Ethernet1/0/24]port link-type trunk
[SWC-Ethernet1/0/24]port trunk permit vlan all
查看交换机上VLAN相关信息
在SWA上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWA上存在的VLAN为VLAN1和VLAN10。
在SWA上执行display vlan 10命令可以查看VLAN10的相关信息,通过执行该命令后的输出信息显示可以看到VLAN10中包含了端口Ethernet1/0/24,且数据帧是以tagged(tagged/untagged)的形式通过端口的。
在SWB上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWB上存在的VLAN为VLAN1。
在SWC上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWC上存在的VLAN为VLAN1和VLAN10。
在SWC上执行display vlan 10命令可以查看VLAN10的相关信息,通过执行该命令后的输出信息显示可以看到VLAN10中包含了端口Ethernet1/0/24,且数据帧是以tagged(tagged/untagged)的形式通过端口的。
跨交换机VLAN互通测试
我们在PC上配置IP地址,通过Ping命令来测试处于相同VLAN内的PC能否互通。
IP地址列表
设备名称        IP地址        网关
PCA        192.168.1.1        --
PCB        192.168.2.1        --
PCC        192.168.1.2        --
PCD        192.168.2.2        --
按表2-2所示在PCA和PCC上配置IP地址。
在PCA上用Ping命令来测试与PCC能否互通,其结果应该是不能(能/不能)互通。出现这种情况的原因是交换机只会转发本交换机存在VLAN的数据帧,SWA和SWC上都存在VLAN10,而SWB上只有缺省的VLAN1。PCA访问PCC时,SWA从Ethernet1/0/24端口转发PCA发出的数据帧时带有VLAN10的标签,SWB接收到此数据帧检查VLAN标签为VLAN10,发现本交换机没有VLAN10,没法查找到出端口,所以把数据帧丢弃(转发/丢弃)。
要想让PCA与PCC之间能够互通,SWB上需要有VLAN10,并且在Trunk端口Ethernet1/0/23和Ethernet1/0/24都允许VLAN10通过。可以在SWB上手动配置VLAN10,也可以通过GVRP协议动态学习。本实验主要讨论GVRP动态学习过程,感兴趣的学员可以在SWB上手动配置VLAN10测试一下。
GVRP基本配置
首先配置SWA。
在SWA的系统视图下开启GVRP功能,然后在每一个Trunk端口启用GVRP协议。请在下面的空格中写出完整的配置命令:
[SWA]gvrp
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]gvrp
然后配置SWB。
在SWB的系统视图下开启GVRP功能,然后在每一个Trunk端口启用GVRP协议。请在下面的空格中写出完整的配置命令:
[SWB]gvrp
[SWB]interface Ethernet 1/0/23
[SWB-Ethernet1/0/23]gvrp
[SWB]interface Ethernet 1/0/24
[SWB-Ethernet1/0/24]gvrp   
最后配置SWC。
在SWC的系统视图下开启GVRP功能,然后在每一个Trunk端口启用GVRP协议。请在下面的空格中写出完整的配置命令:
[SWC]gvrp
[SWC]interface Ethernet 1/0/24
[SWC-Ethernet1/0/24]gvrp
在SWB上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWB上存在的VLAN为VLAN1和VLAN10。
在SWB上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWB上存在的动态VLAN为VLAN10。
在SWB上执行display vlan 10命令可以查看VLAN10的相关信息,通过执行该命令后的输出信息显示可以看到VLAN10中包含了端口Ethernet1/0/23和Ethernet1/0/24,且数据帧是以tagged(tagged/untagged)的形式通过端口的。
从以上综合信息可以看出,SWB通过GVRP协议动态学习到了VLAN10,并且Trunk端口Ethernet1/0/23和Ethernet1/0/24都允许VLAN10通过。所以SWB可以转发VLAN10的数据帧。
配置完成后,再在PCA上用Ping命令来测试与PCC能否互通,其结果应该是能(能/不能)互通。
GVRP端口注册模式配置
实验组网如图2-1所示,本实验任务通过在交换机相应端口上改变GVRP端口注册模式,再通过在交换机上查看相关VLAN信息和Trunk端口信息,分析GVRP端口不同注册模式下的注册结果。通过本实验,使读者能够更好的掌握GVRP的原理,从而达到对GVRP熟练应用的目的。
在SWA上配置VLAN20
在实验任务一的基础上,在SWA上创建VLAN20,将PCB所连接的端口Ethernet1/0/2添加到VLAN20中。请在下面的空格中写出完整的配置命令:
[SWA]vlan 20
[SWA-vlan20]port Ethernet 1/0/2
在SWA上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWA上存在的VLAN为VLAN1、VLAN10和VLAN20。
在SWA上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWA上存在的动态VLAN为无。
在SWB上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWB上存在的VLAN为VLAN1、VLAN10和VLAN20。
在SWB上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWB上存在的动态VLAN为VLAN10和VLAN20。
在SWC上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWC上存在的VLAN为VLAN1、VLAN10和VLAN20。
在SWC上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWC上存在的动态VLAN为VLAN20。
从以上综合信息可以看出,在SWA上手动配置VLAN20后,通过GVRP协议,SWB和SWC都动态学习到的VLAN为VLAN20 。
在SWA上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1、VLAN10和VLAN20。       
在SWB上执行display interface Ethernet 1/0/23命令可以查看端口Ethernet1/0/23的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1、VLAN10和VLAN20。       
在SWB上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1和VLAN10。
在SWC上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1、VLAN10和VLAN20。       
从以上综合信息可以看出,SWB的Trunk端口Ethernet1/0/24上VLAN20实际不能通过,这是为什么呢?出现这种情况的原因是GVRP协议进行VLAN属性的声明注册过程是沿着网络路径单向传播的。
VLAN20的声明注册过程为:SWA静态配置VLAN20,SWA的Trunk端口Ethernet1/0/24声明VLAN20的属性,SWB的Trunk端口Ethernet1/0/23注册VLAN20属性,再通过SWB的Trunk端口Ethernet1/0/24声明VLAN20属性,SWC的Trunk端口Ethernet1/0/24注册该属性。
由于SWC上没有手动配置VLAN20,SWB 的Trunk端口Ethernet1/0/24不会收到VLAN20的声明属性,从而也不会注册VLAN20。所以SWB的Trunk端口Ethernet1/0/24不会允许VLAN20通过。下面可以通过在SWC上配置VLAN20来进行验证。
在SWC上配置VLAN20
在SWC上创建VLAN20,将PCD所连接的端口Ethernet1/0/2添加到VLAN20中,请在下面的空格中写出完整的配置命令:
[SWC]vlan 20
[SWC-vlan20]port Ethernet 1/0/2
在SWB上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1、VLAN10和VLAN20。       
按表2-2所示在PCB和PCD上配置IP地址。配置完成后,在PCB上用Ping命令来测试与PCD能否互通,其结果应该是能(能/不能)互通的。
GVRP端口Fixed注册模式配置
在SWA的Trunk端口Ethernet1/0/24修改GVRP端口注册模式为Fixed,请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]gvrp registration fixed
第二条配置命令的含义是:Fixed模式禁止该端口动态注册或注销VLAN,只传播静态VLAN信息,不传播动态VLAN信息。也就是说被设置为Fixed模式的Trunk端口,即使允许所有VLAN通过,实际通过的VLAN也只能是手动配置的静态VLAN。
在SWC上增加如下配置:
[SWC]vlan 30
在SWC上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWC上存在的VLAN为VLAN1、VLAN10、VLAN20和VLAN30。
在SWA上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWA上存在的VLAN为VLAN1、VLAN10和VLAN20。
在SWA上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWA上存在的动态VLAN为无。
在SWB上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWB上存在的VLAN为VLAN1、VLAN10、VLAN20和VLAN30。
在SWB上执行display vlan dynamic命令查看动态VLAN信息,通过执行该命令后的输出信息显示可以看到SWB上存在的动态VLAN为VLAN10、VLAN20和VLAN30。
从以上综合信息可以看出,在SWC上手动配置VLAN30后,通过GVRP协议,SWB动态学习到了VLAN30,而SWA没有动态学习到VLAN30。
出现这种情况的原因是在SWA的Trunk端口Ethernet1/0/24配置了GVRP端口注册模式为Fixed,也就是说SWA的Trunk端口Ethernet1/0/24不会接收从对端来的动态VLAN信息。
在SWA上执行display gvrp statistics命令查看Trunk端口的GVRP统计信息,通过执行该命令后的输出信息显示可以看到SWA的Ethernet1/0/24端口的GVRP注册模式为Fixed。
在SWA上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1、VLAN10和VLAN20。       
从以上综合信息可以看出,SWA的Trunk端口Ethernet1/0/24被设置为Fixed注册模式后,不会注册VLAN30。即实际通过的VLAN也只能是本交换机手动配置的静态VLAN1、VLAN10和VLAN20。
GVRP端口Forbidden注册模式配置
在SWA的Trunk端口Ethernet1/0/24修改GVRP端口注册模式为Forbidden,请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]gvrp registration forbidden
第二条配置命令的含义是:Forbidden模式禁止该端口动态注册或注销VLAN,不传播除VLAN 1以外的任何的VLAN信息。也就是说被配置为Forbidden模式的Trunk端口,即使允许所有VLAN通过,实际通过的VLAN也只能是VLAN 1。
在SWA上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWA上存在的VLAN为VLAN1、VLAN10和VLAN20。
在SWA上执行display gvrp statistics命令查看Trunk端口的GVRP统计信息,通过执行该命令后的输出信息显示可以看到SWA的Ethernet1/0/24端口的GVRP注册模式为Forbidden。
在SWA上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet1/0/24的信息,通过执行该命令后的输出信息显示可以看到,端口实际通过的VLAN为VLAN1。
从以上综合信息可以看出,SWA的Trunk端口Ethernet1/0/24被配置为Forbidden注册模式后,即使该端口允许所有VLAN通过,实际通过的VLAN也只能是VLAN1。
 楼主| 发表于 2013-10-21 14:50:28 | 显示全部楼层
*Isolate-user-vlan
实验任务的描述
实验组网如图3-1所示,本实验任务通过在交换机上配置Isolate-user-vlan和Secondary VLAN,Isolate-user-vlan映射Secondary VLAN,使得Secondary VLAN间不能互通,但每个Secondary VLAN都可以和Isolate-user-vlan互通。通过本实验,学员能够掌握Isolate-user-vlan的特性和工作原理,并且能够学会交换机上Isolate-user-vlan的基本配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置Isolate-user-vlan
在SWA上创建VLAN2、VLAN3和VLAN10,将PCA所连接的端口GigabitEhernet1/0/1添加到VLAN2中,将PCB所连接的端口GigabitEhernet1/0/2添加到VLAN3中,将SWA连接SWB的端口GigabitEhernet1/0/3添加到VLAN10中。设置VLAN10为Isolate-user-vlan,VLAN2和VLAN3为Secondary VLAN,配置Isolate-user-vlan和Secondary VLAN间的映射关系。请在下面的空格中写出完整的配置命令:
[SWA]vlan 2
[SWA-vlan2]port GigabitEthernet 1/0/1
[SWA]vlan 3                    
[SWA-vlan3]port GigabitEthernet 1/0/2
[SWA]vlan 10
[SWA-vlan10]port GigabitEthernet 1/0/3
[SWA-vlan10]isolate-user-vlan enable(设置VLAN10为Isolate-user-vlan)
[SWA]isolate-user-vlan 10 secondary 2 3(配置Isolate-user-vlan和Secondary VLAN间的映射关系)
配置完成后,在SWA上执行display current-configuration命令查看当前配置,请在下面的空格中写出相关接口下完整的配置结果:
interface GigabitEthernet1/0/1
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 10 untagged
port hybrid pvid vlan 2
#
interface GigabitEthernet1/0/2
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 3 10 untagged
port hybrid pvid vlan 3
#
interface GigabitEthernet1/0/3
port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2 to 3 10 untagged
port hybrid pvid vlan 10
在SWA上执行display isolate-user-vlan命令,查看Isolate-user-vlan和Secondary VLAN的映射关系以及Isolate-user-vlan和Secondary VLAN映射关系的端口,通过执行该命令后的输出信息显示可以看到VLAN2包含了端口GigabitEthernet1/0/1和GigabitEthernet1/0/3,VLAN3包含了端口GigabitEthernet1/0/2和GigabitEthernet1/0/3,VLAN10中包含了端口GigabitEthernet1/0/1、GigabitEthernet1/0/2和GigabitEthernet1/0/3,且数据帧都是以untagged(tagged/untagged)的形式通过端口的。
从以上信息可以看出,Isolate-user-vlan实际上是通过交换机hybrid链路端口的灵活属性来实现的。即交换机通过批处理的方式配置一系列的Hybrid端口,并对来自不同VLAN的数据帧进行是否打VLAN 标签处理,从而达到Secondary VLAN和Isolate-user-vlan互通(互通/隔离),但Secondary VLAN之间隔离(互通/隔离)的目的。
Secondary VLAN互通测试
在PC上配置IP地址,通过Ping命令来测试处于不同Secondary VLAN间的PC能否互通。
IP地址列表
设备名称        接口        IP地址        网关
PCA        --        192.168.1.1        --
PCB        --        192.168.1.2        --
SWB        Vlan-interface20        192.168.1.3        --
按表3-2所示在PC上配置IP地址。
配置完成后,在PCA上用Ping命令来测试与PCB能否互通,其结果应该是不能(能/不能)互通。
Secondary VLAN和Isolate-user-vlan互通测试
在SWB上创建VLAN20,将SWB连接SWA的端口GigabitEhernet1/0/3添加到VLAN20中。并按表3-2所示给VLAN20的虚接口配置IP地址192.168.1.3/24。请在下面的空格中填写完整的配置命令:
[SWB]vlan 20
[SWB-vlan20]port GigabitEthernet 1/0/3
[SWB]interface Vlan-interface 20
[SWB-Vlan-interface20]ip address 192.168.1.3 255.255.255.0
配置完成后,在SWB上系统视图下用Ping命令来测试与PCA和PCB能否互通,其结果应该是SWB与PCA能(能/不能)互通,SWB与PCB能(能/不能)互通。
查看SWA和SWB的MAC地址表
 在SWA上执行display mac-address命令查看SWA的MAC地址表,然后根据此输出结果补充表3-3内容:
SWA的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
aaaa-aaaa-aaaa        2        Learned        GigabitEthernet1/0/1        AGING
bbbb-bbbb-bbbb        3        Learned        GigabitEthernet1/0/2        AGING
MAC_SWB        10        Learned        GigabitEthernet1/0/3        AGING
aaaa-aaaa-aaaa        10        Learned        GigabitEthernet1/0/1        AGING
bbbb-bbbb-bbbb        10        Learned        GigabitEthernet1/0/2        AGING
从表3-3的信息可以看出,PCA的MAC被学习到了VLAN2和VLAN10中,PCB的MAC地址被学习到了VLAN3和VLAN10中。
因为S5500-EI系列交换机使用V5软件平台,V5软件平台从设计规格上将Secondary VLAN学习到的MAC地址复制到Isolate-user-vlan中,但是不将Isolate-user-vlan学习到的MAC地址复制到Secondary VLAN。以前使用V3软件平台的交换机会把Isolate-user-vlan学习到的MAC地址复制到Secondary VLAN。
 在SWB上执行display arp命令查看SWB的ARP地址表,然后根据此输出结果补充表3-4内容:
SWB的ARP表
IP Address        MAC Address        VLAN ID        Interface        Aging        Type
192.168.1.1        aaaa-aaaa-aaaa        20        GE1/0/3                D
192.168.1.2        bbbb-bbbb-bbbb        20        GE1/0/3                D
从表3-4中可以看到, ARP表中对应的Type值为D表示:该ARP表项是动态学习到的。
 在SWB上执行display mac-address命令查看SWB的MAC地址表,然后根据此输出结果补充表3-5内容:
SWB的MAC地址表
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
MAC_SWA        20        Learned        GigabitEthernet1/0/3        AGING
aaaa-aaaa-aaaa        20        Learned        GigabitEthernet1/0/3        AGING
bbbb-bbbb-bbbb        20        Learned        GigabitEthernet1/0/3        AGING
从表3-5的信息可以看出,对SWB来说,PCA和PCB相当于在VLAN20内,对SWA上的VLAN2和VLAN3不可见。
配置本地代理ARP
如果想让PCA和PCB互通,需要在SWB的VLAN20虚接口上开启本地代理ARP功能。请在下面的空格中写出完整的配置命令:
[SWB]interface Vlan-interface 20
[SWB-Vlan-interface20]local-proxy-arp enable
此时,在PCA上用Ping命令来测试与PCB能否互通,其结果应该是能(能/不能)互通。
 楼主| 发表于 2013-10-22 16:07:54 | 显示全部楼层
VLAN VPN
VLAN VPN基本配置
实验组网图图4-1所示,本实验通过在交换机相应端口上开启QinQ功能,使得PCA可以访问PCB,再通过抓包来分析QinQ报文的双层VLAN标签(Tag)。通过本实验,使学员能够更好的掌握VLAN VPN的基本原理和配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
SWC和SWD基本VLAN配置
在SWC上创建VLAN10,将PCA所连接的端口Ethernet1/0/3添加到VLAN10中,配置端口Ethernet1/0/1为Trunk链路端口,并允许VLAN10通过。请在下面的空格中写出完整的配置命令:
[SWC]vlan 10
[SWC-vlan10]port Ethernet 1/0/3
[SWC]interface Ethernet 1/0/1
[SWC-Ethernet1/0/1]port link-type trunk
[SWC-Ethernet1/0/1]port trunk permit vlan 10
在SWD上创建VLAN10,将PCB所连接的端口Ehernet1/0/3添加到VLAN10中,配置端口Ethernet1/0/2为Trunk链路端口,并允许VLAN10通过。请在下面的空格中写出完整的配置命令:
[SWD]vlan 10
[SWD-vlan10]port Ethernet 1/0/3
[SWD]interface Ethernet 1/0/2
[SWD-Ethernet1/0/2]port link-type trunk
[SWD-Ethernet1/0/2]port trunk permit vlan 10
在PC上配置IP地址,通过Ping命令来测试PCA和PCB能否互通。
IP地址列表
设备名称        IP地址        网关
PCA        192.168.1.1        --
PCB        192.168.1.2        --
按表4-2所示在PC上配置IP地址。
配置完成后,在PCA上用Ping命令来测试与PCB能否互通,其结果应该是不能(能/不能)互通。出现这种情况的原因是SWA和SWB为缺省配置,所有端口缺省是Access链路端口,且属于VLAN1,不能识别VLAN10的数据帧。
VLAN VPN配置
在SWA上创建VLAN2,将和SWC互连的端口Ethernet1/0/1添加到VLAN2中,并在端口Ethernet1/0/1开启QinQ功能;在SWA上配置端口Ethernet1/0/24为Trunk链路端口,并允许VLAN2通过。请在下面的空格中写出完整的配置命令:
[SWA]vlan 2
[SWA-vlan2]port Ethernet 1/0/1
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1]qinq enable
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]port link-type trunk
[SWA-Ethernet1/0/24]port trunk permit vlan 2
在SWB上创建VLAN2,将和SWD互连的端口Ethernet1/0/2添加到VLAN2中,并在端口Ethernet1/0/2开启QinQ功能。在SWB上配置端口Ethernet1/0/24为Trunk链路端口,并允许VLAN2通过。请在下面的空格中写出完整的配置命令:
[SWB]vlan 2
[SWB-vlan2]port Ethernet 1/0/2
[SWB]interface Ethernet 1/0/2
[SWB-Ethernet1/0/2]qinq enable
[SWB]interface Ethernet 1/0/24
[SWB-Ethernet1/0/24]port link-type trunk
[SWB-Ethernet1/0/24]port trunk permit vlan 2
配置完成后,再在PCA上用Ping命令来测试与PCB能否互通,其结果应该是能(能/不能)互通。
在SWA上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWA上存在的VLAN为VLAN1和VLAN2。
在SWB上执行display vlan命令查看VLAN相关信息,通过执行该命令后的输出信息显示可以看到SWB上存在的VLAN为VLAN1和VLAN2。
在SWA上配置镜像,镜像端口为Ethernet1/0/24,监控端口为Ethernet1/0/10。请在下面的空格中写出完整的配置命令:
[SWA]mirroring-group 1 local
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]mirroring-group 1 mirroring-port both
[SWA]interface Ethernet 1/0/10
[SWA-Ethernet1/0/10]mirroring-group 1 monitor-port
在SWA的端口Ethernet1/0/10接一台PCC,PCC上安装抓包软件,比如Wireshark。在PCA上用Ping命令测试与PCB互通时,在PCC上开始抓包,抓到的数据帧带两层802.1Q标签(Tag),如下图所示:

注意:
PCC抓包抓到的数据帧是否带两层802.1Q标签(Tag),与PCC的网卡有关,有的网卡不能识别外层的802.1Q数据帧,抓到的数据帧只带内层标签(Tag)。可以在两台交换机之间串接一个HUB,把PCC接在HUB上,利用HUB的广播特性来抓包。
BPDU Tunnel基本配置
实验组网如图4-2所示,本实验通过在交换机上配置BPDU Tunnel,使得STP协议报文透明穿越运营商网络,并且PCA可以访问PCB,再通过抓包来分析STP协议报文穿越BPDU Tunnel时MAC地址的变化过程。通过本实验,使学员能够更好的掌握BPDU Tunnel的基本原理和配置。
建立物理环路连接
在实验任务一的基础上,按照图4-2所示进行连接。
在SWA上将和SWC互连的端口Ethernet1/0/2添加到VLAN2中,并在端口Ethernet1/0/2开启QinQ功能。请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/2
[SWA-Ethernet1/0/2]port access vlan 2
[SWA-Ethernet1/0/2]qinq enable  
在SWB上将和SWD互连的端口Ethernet1/0/1添加到VLAN2中,并在端口Ethernet1/0/1开启QinQ功能。请在下面的空格中写出完整的配置命令:
[SWB]interface Ethernet 1/0/1
[SWB-Ethernet1/0/1]port access vlan 2
[SWB-Ethernet1/0/1]qinq enable
在PCA上执行命令“ping 192.168.1.2 -t”,以使PCA向PCB不间断发送ICMP报文。可以看到所有交换机的接口灯闪烁异常频繁,说明网络有环路了,此时在SWC上执行display interface Ethernet 1/0/2命令查看SWC的端口Ethernet1/0/2当前的运行状态和相关信息,依据该命令输出的信息,可以看到SWC的端口Ethernet1/0/2输入输出接近100%都是广播包(单播包/广播包)。
SWC和SWD开启STP功能
在SWC上系统视图下执行stp enable命令开启STP功能。
在SWD上开启STP功能并设置SWD的优先级为4096。请在下面的空格中写出完整的配置命令:
[SWD]stp enable
[SWD]stp priority 4096
在SWC上执行display interface Ethernet 1/0/1命令查看端口Ethernet1/0/1当前的运行状态和相关信息,依据该命令输出的信息,可以看到该接口的MAC地址为hhhh-hhhh-hhhh。
在SWD上执行display interface Ethernet 1/0/1命令查看端口Ethernet1/0/1当前的运行状态和相关信息,依据该命令输出的信息,可以看到该接口的MAC地址为hhhh-hhhh-hhhh。
 在SWC上执行display stp root命令查看SWC上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-3内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        4096.000f-e273-0381        200        0        Ethernet1/0/1
 在SWC上执行display stp brief命令查看SWC上STP的摘要信息,然后根据此输出结果补充表4-4内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        ROOT        FORWARDING        NONE
0        Ethernet1/0/2        ALTE        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
 在SWD上执行display stp root命令查看SWD上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-5内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        4096.000f-e273-0381        0        0       
 在SWD上执行display stp brief命令查看SWD上STP的摘要信息,然后根据此输出结果补充表4-6内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        DESI        FORWARDING        NONE
0        Ethernet1/0/2        BACK        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
从以上信息可以看出,SWD是STP的根交换机,SWC的端口Ethernet1/0/1为根端口。
SWA和SWB开启STP功能
在SWA上系统视图下执行stp enable命令开启STP功能。
在SWB上开启STP功能并设置SWB的优先级为0。请在下面的空格中写出完整的配置命令:
[SWB]stp enable
[SWB]stp priority 0
 在SWA上执行display stp root命令查看SWA上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-7内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        0.000f-e23e-f900        200        0        Ethernet1/0/24
 在SWA上执行display stp brief命令查看SWA上STP的摘要信息,然后根据此输出结果补充表4-8内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        DESI        FORWARDING        NONE
0        Ethernet1/0/2        DESI        FORWARDING        NONE
0        Ethernet1/0/24        ROOT        FORWORDING        NONE
 在SWB上执行display stp root命令查看SWB上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-9内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        0.000f-e23e-f900        0        0       
 在SWB上执行display stp brief命令查看SWB上STP的摘要信息,然后根据此输出结果补充表4-10内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        DESI        FORWARDING        NONE
0        Ethernet1/0/2        DESI        FORWARDING        NONE
0        Ethernet1/0/24        DESI        FORWORDING        NONE
 在SWC上执行display stp root命令查看SWC上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-11内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        0.000f-e23e-f900        400        0        Ethernet1/0/1
 在SWC上执行display stp brief命令查看SWC上STP的摘要信息,然后根据此输出结果补充表4-12内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        ROOT        FORWARDING        NONE
0        Ethernet1/0/2        ALTE        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
 在SWD上执行display stp root命令查看SWD上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-13内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        0.000f-e23e-f900        0        0       
 
 在SWD上执行display stp brief命令查看SWD上STP的摘要信息,然后根据此输出结果补充表4-14内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        ROOT        FORWARDING        NONE
0        Ethernet1/0/2        ALTE        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
从以上综合信息可以看出,当SWA和SWB也开启STP功能后,四台交换机都一起参与了STP计算,计算的结果是SWB为STP的根交换机,SWC和SWD的端口Ethernet1/0/1为根(根/指定)端口。
BPDU Tunnel基本配置
为了能使SWC和SWD的STP BPDU报文透传SWA和SWB,需要在SWA和SWB上配置BPDU Tunnel,并且在系统视图下修改BPDU Tunnel帧采用的组播目的MAC地址为0100.0CCD.CDD0。请在下面的空格中写出完整的配置命令:
首先配置SWA。
[SWA]bpdu-tunnel tunnel-dmac 0100-0ccd-cdd0
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1]stp disable (关闭端口的STP功能)
[SWA-Ethernet1/0/1]bpdu-tunnel dot1q stp (开启端口的STP协议的BPDU Tunnel功能)
[SWA]interface Ethernet 1/0/2
[SWA-Ethernet1/0/2]stp disable  (关闭端口的STP功能)           
[SWA-Ethernet1/0/2]bpdu-tunnel dot1q stp (开启端口的STP协议的BPDU Tunnel功能)  
然后配置SWB。
[SWB]bpdu-tunnel tunnel-dmac 0100-0ccd-cdd0
[SWB]interface Ethernet 1/0/1
[SWB-Ethernet1/0/1]stp disable (关闭端口的STP功能)
[SWB-Ethernet1/0/1]bpdu-tunnel dot1q stp (开启端口的STP协议的BPDU Tunnel功能)
[SWB]interface Ethernet 1/0/2
[SWB-Ethernet1/0/2]stp disable (关闭端口的STP功能)           
[SWB-Ethernet1/0/2]bpdu-tunnel dot1q stp (开启端口的STP协议的BPDU Tunnel功能)  
 配置完成后,在SWC上执行display stp root命令查看SWC上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-15内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        4096.000f-e273-0381        200        0        Ethernet1/0/1
 在SWC上执行display stp brief命令查看SWC上STP的摘要信息,然后根据此输出结果补充表4-16内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        ROOT        FORWARDING        NONE
0        Ethernet1/0/2        ALTE        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
 在SWD上执行display stp root命令查看SWD上所有MSTP实例的根桥信息,然后根据此输出结果补充表4-17内容:
display stp root命令显示信息描述表
MSTID        Root Bridge ID        ExtPathCost        IntPathCost        Root Port
0        4096.000f-e273-0381        0        0       
 在SWD上执行display stp brief命令查看SWD上STP的摘要信息,然后根据此输出结果补充表4-18内容:
display stp brief命令显示信息描述表
MSTID        Port        Role        STP State        Protection
0        Ethernet1/0/1        DESI        FORWARDING        NONE
0        Ethernet1/0/2        BACK        DISCARDING        NONE
0        Ethernet1/0/3        DESI        FORWORDING        NONE
从以上综合信息可以看出,当SWA和SWB配置BPDU Tunnel后,SWC和SWD重新计算STP,计算的结果是SWD为根交换机,SWC的端口Ethernet1/0/1为根端口。而此时PCA和PCB仍然可以互通。
抓包分析BPDU Tunnel报文
在PCC上再开始抓包,抓到的STP协议报文目的MAC地址已经由0180-C200-0000修改为组播MAC地址0100-0CCD-CDD0,如下图所示:

在SWA上取消镜像端口Ethernet1/0/24,配置端口Ethernet1/0/1为新的镜像端口,监控端口仍然为Ethernet1/0/10。请在下面的空格中写出完整的配置命令:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]undo mirroring-group 1 mirroring-port both
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1] mirroring-group 1 mirroring-port both
在PCC上再开始抓包,抓到的STP协议报文目的MAC地址已经还原为0180-C200-0000,如下图所示:
 楼主| 发表于 2013-10-22 16:09:04 | 显示全部楼层
VLAN静态路由
静态路由配置
实验组网如图5-1所示,本实验主要是通过在交换机上配置静态路由,从而达到PC之间能够互访的目的。通过本实验,读者能够掌握交换机上静态路由和缺省路由的配置。
建立物理连接
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置VLAN虚接口和IP地址
在SWA上创建VLAN10和VLAN40,将端口Ethernet1/0/1和Ethernet1/0/24分别添加到VLAN10和VLAN40中。请在下面的空格中写出完整的配置命令:
[SWA]vlan 10
[SWA-vlan10]port Ethernet 1/0/1
[SWA]vlan 40
[SWA-vlan40]port Ethernet 1/0/24
在SWB上创建VLAN20、VLAN40和VLAN50,将端口Ethernet1/0/1、Ethernet1/0/23和Ethernet1/0/24分别添加到VLAN20、VLAN40和VLAN50中。请在下面的空格中写出完整的配置命令:
[SWB]vlan 20
[SWB-vlan20]port Ethernet 1/0/1
[SWB]vlan 40
[SWB-vlan40]port Ethernet 1/0/23
[SWB]vlan 50
[SWB-vlan50]port Ethernet 1/0/24
在SWC上创建VLAN30和VLAN50,将端口Ethernet1/0/1和Ethernet1/0/24分别添加到VLAN30和VLAN50中。请在下面的空格中写出完整的配置命令:
[SWC]vlan 30
[SWC-vlan30]port Ethernet 1/0/1
[SWC]vlan 50
[SWC-vlan50]port Ethernet 1/0/24
IP地址列表
设备名称        接口        IP地址        网关
SWA        Vlan-interface10        10.1.1.1/24        --
        Vlan-interface40        40.1.1.1/24        --
SWB        Vlan-interface20        20.1.1.1/24        --
        Vlan-interface40        40.1.1.2/24        --
        Vlan-interface50        50.1.1.2/24        --
SWC        Vlan-interface30        30.1.1.1/24        --
        Vlan-interface50        50.1.1.1/24        --
PCA        --        10.1.1.2/24        10.1.1.1
PCB        --        20.1.1.2/24        20.1.1.1
PCC        --        30.1.1.2/24        30.1.1.1
按表5-2所示在交换机上给各VLAN虚接口分别配置IP地址。请在下面的空格中写出完整的配置命令:
首先配置SWA。
[SWA]interface Vlan-interface 10
[SWA-Vlan-interface10]ip address 10.1.1.1 255.255.255.0
[SWA]interface Vlan-interface 40
[SWA-Vlan-interface40]ip address 40.1.1.1 255.255.255.0
然后配置SWB。
[SWB]interface Vlan-interface 20
[SWB-Vlan-interface20]ip address 20.1.1.1 255.255.255.0
[SWB]interface Vlan-interface 40      
[SWB-Vlan-interface40]ip address 40.1.1.2 255.255.255.0
[SWB]interface Vlan-interface 50      
[SWB-Vlan-interface50]ip address 50.1.1.2 255.255.255.0
最后配置SWC。
[SWC]interface Vlan-interface 30
[SWC-Vlan-interface30]ip address 30.1.1.1 255.255.255.0
[SWC]interface Vlan-interface 50      
[SWC-Vlan-interface50]ip address 50.1.1.1 255.255.255.0
配置静态路由
在SWA上配置缺省路由,下一跳地址分别为40.1.1.2。请在下面的空格中写出完整的配置命令:
[SWA]ip route-static 0.0.0.0 0.0.0.0 40.1.1.2
在SWB上配置两条静态路由,目的地址为10.1.1.0/24的下一跳IP地址为40.1.1.1,目的地址为30.1.1.0/24的下一跳IP地址为50.1.1.1。请在下面的空格中写出完整的配置命令:
[SWB]ip route-static 10.1.1.0 255.255.255.0 40.1.1.1
[SWB]ip route-static 30.1.1.0 255.255.255.0 50.1.1.1
在SWC上配置缺省路由,下一跳地址分别为50.1.1.2。请在下面的空格中写出完整的配置命令:
[SWC]ip route-static 0.0.0.0 0.0.0.0 50.1.1.2
注意:
在配置静态路由时,建议不要直接指定广播类型接口作出接口(如VLAN接口等)。因为广播类型的接口,会导致出现多个下一跳,无法唯一确定下一跳。在某些特殊应用中,如果必须配置广播接口(如VLAN接口等)为出接口,则必须同时指定其对应的下一跳地址。
配置完成后,查看各交换机的路由表。例如,在SWB上执行display ip routing-table命令查看路由表,由该命令输出结果可知,SWB上配置了两条静态路由后,路由表中除了直连路由,又生成两条静态路由,缺省优先级为60。
按表5-2所示在PC上配置IP地址和网关,在PCA上用Ping命令来测试到PCB和PCC的互通性,其结果应该是PCA与PCB能(能/不能)互通,PCA和PCC能(能/不能)互通。
 楼主| 发表于 2013-10-25 14:55:19 | 显示全部楼层
RSTP
在交换机上配置RSTP
查看环路引起的广播风暴对网络的影响
按照实验环境组网图连接交换机,交换机各端口均属于VLAN1,PCA的IP地址为2.2.2.1/24,PCB的IP地址配置为2.2.2.2/24。
由于网络中存在环路,此时可以看到交换机的所有互联端口以及连接主机的端口的指示灯均快速闪动,表示形成了广播风暴。此时PCA 无法ping通PCB。
C:\Documents and Settings\wakin>ping 2.2.2.2
Pinging 2.2.2.2 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 2.2.2.2:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
在交换机上启用RSTP
在SWA上通过命令stp mode配置生成树协议的模式为RSTP,通过命令stp enable在交换机上使能生成树协议。
[SWA]stp mode rstp
[SWA]stp enable
SWB、SWC、SWD的配置和SWA相同。启用生成树协议后可以看到交换机各端口指示灯停止快速闪动,网络恢复正常。此时PCA可以ping通PCB。
C:\Documents and Settings\wakin>ping 2.2.2.2
Pinging 2.2.2.2 with 32 bytes of data:
Reply from 2.2.2.2: bytes=32 time<1ms TTL=128
Reply from 2.2.2.2: bytes=32 time<1ms TTL=128
Reply from 2.2.2.2: bytes=32 time<1ms TTL=128
Reply from 2.2.2.2: bytes=32 time<1ms TTL=128

Ping statistics for 2.2.2.2:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
查看网络中的根桥
通过命令display stp root可以查看网络中的根桥ID以及本网桥的根端口信息。例如在SWA上查看根桥信息如下:
<SWA>display stp root
MSTID  Root Bridge ID         ExtPathCost IntPathCost Root Port
   0     32768.000f-e23d-59f0 400           0             Ethernet1/0/23
从上述信息可以得知网络中根桥的ID为32768.000f-e23d-59f0,SWA的根端口为连接SWB的端口E1/0/23。SWA到达根桥的路径开销为400。
在SWB上查看根桥信息如下:
<SWB>display stp root
MSTID  Root Bridge ID          ExtPathCost IntPathCost Root Port
   0    32768.000f-e23d-59f0    200           0            Ethernet1/0/24
可以得知SWB的根端口为连接SWD的端口E1/0/24。SWC到达根桥的路径开销为200。
在SWD上查看根桥信息如下:
<SWD>display stp root
MSTID  Root Bridge ID        ExtPathCost IntPathCost Root Port
   0    32768.000f-e23d-59f0  0             0     
SWD不存在根端口,到达根桥的路径开销为0,说明SWD即为网络中的根桥。
查看SWD的MAC地址即为根桥ID中的MAC地址:
<SWD>display interface Ethernet1/0/1
Ethernet1/0/1 current state: DOWN
IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 000f-e23d-59f0
……
查看各交换机端口的角色
通过命令display stp brief可以查看交换机各端口的STP状态以及端口角色。
例如,查看SWA的端口状态以及端口角色如下:
<SWA>display stp brief
MSTID      Port                         Role  STP State     Protection
   0        Ethernet1/0/23               ROOT  FORWARDING    NONE
   0        Ethernet1/0/24               ALTE  DISCARDING    NONE
可以看到SWA的端口E1/0/23为根端口,状态为Forwarding状态;端口E1/0/24为Alternate端口,状态为Discarding状态。
查看STP详细信息
通过命令display stp可以查看STP的详细信息,包含全局参数如根桥ID、根路径开销、STP定时器参数等信息,还包含接口参数端口开销、端口角色、端口优先级等参数。
例如,查看SWA的STP详细信息如下:
<SWA>display stp
-------[CIST Global Info][Mode RSTP]-------
CIST Bridge         :32768.000f-e24a-df50
Bridge Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC      :32768.000f-e23d-59f0 / 400
CIST RegRoot/IRPC  :32768.000f-e24a-df50 / 0
CIST RootPortId     :128.23
BPDU-Protection     :disabled
Bridge Config-            
Digest-Snooping     :disabled
TC or TCN received  :90
Time since last TC  :0 days 0h:12m:7s
……
……
----[Port23(Ethernet1/0/23)][FORWARDING]----
Port Protocol       :enabled
Port Role           :CIST Root Port
Port Priority      :128
Port Cost(Legacy) :Config=auto / Active=200
Desg. Bridge/Port :32768.000f-e23e-f9b0 / 128.22
Port Edged          Config=disabled / Active=disabled
Point-to-point     :Config=auto / Active=true
Transmit Limit     :10 packets/hello-time
Protection Type    :None
MST BPDU Format    Config=auto / Active=legacy
Port Config-            
Digest-Snooping    :disabled
Num of Vlans Mapped :1
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 1s RemHop 0
BPDU Sent           :6            
          TCN: 0, Config: 0, RST: 6, MST: 0
BPDU Received       :941            
          TCN: 0, Config: 0, RST: 941, MST: 0

----[Port24(Ethernet1/0/24)][DISCARDING]----
Port Protocol       :enabled
Port Role           :CIST Alternate Port
Port Priority       :128
Port Cost(Legacy)  :Config=auto / Active=200
Desg. Bridge/Port  :32768.000f-e245-6bc0 / 128.22
Port Edged          :Config=disabled / Active=disabled
Point-to-point      :Config=auto / Active=true
Transmit Limit      :10 packets/hello-time
Protection Type     :None
MST BPDU Format     :Config=auto / Active=legacy
Port Config-            
Digest-Snooping     :disabled
Num of Vlans Mapped :1
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 1s RemHop 0
BPDU Sent           :5            
          TCN: 0, Config: 0, RST: 5, MST: 0
BPDU Received       :943            
          TCN: 0, Config: 0, RST: 943, MST: 0
修改交换机的桥优先级
修改SWA的桥优先级
使用命令stp priority将SWA的桥优先级设置为0:
[SWA]stp priority 0
查看当前网络中的根桥
在SWA上查看根桥信息:
[SWA]display stp root
MSTID  Root Bridge ID        ExtPathCost IntPathCost Root Port
   0    0.000f-e24a-df50      0           0  
可以看到,SWA到达根桥路径为0,即SWA成为网络中新的根桥。
查看SWA的MAC地址:
[SWA]display interface  Ethernet 1/0/1
Ethernet1/0/1 current state: DOWN
IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 000f-e24a-df50
Description: Ethernet1/0/1 Interface
……
可以看到SWA的MAC地址即为当前根桥ID中的MAC地址。
此时,在其他网桥上通过命令display stp root也可以看到网络中新的根桥为SWA。
例如在SWD上进行查看:
<SWD>display stp root
MSTID  Root Bridge ID        ExtPathCost IntPathCost Root Port
   0    0.000f-e24a-df50      400         0                Ethernet1/0/23

<SWD>display stp brief
MSTID      Port                         Role  STP State     Protection
   0        Ethernet1/0/23               ROOT  FORWARDING    NONE
   0        Ethernet1/0/24               ALTE  DISCARDING    NONE
当前根桥为SWA,SWD的根端口为E1/0/23,到达根桥的路径开销为400。
修改端口开销
配置SWD端口E1/0/23的端口开销值
在端口视图通过命令stp cost可以修改端口的开销值。本例中,将SWD当前根端口E1/0/23的端口开销从默认值200修改为400。
[SWD-Ethernet1/0/23]stp cost 400
查看SWD端口角色的变化
此时通过命令display stp brief查看SWD的端口角色和状态:
[SWD]display stp brief
MSTID      Port                    Role  STP State     Protection
   0        Ethernet1/0/23        ALTE   DISCARDING     NONE
   0        Ethernet1/0/24        ROOT   FORWARDING     NONE
可以看到通过增加SWD原根端口E1/0/23的端口开销后,该端口由于根路径开销增加而转变为Alternate端口,端口E1/0/24成为SWD新的根端口。
配置边缘端口
没有配置边缘端口时,查看端口的状态转移过程
在没有配置边缘端口时,SWB的端口E1/0/1和SWC的端口E1/0/1需要经过2倍的Forwarding Delay时间,即默认30秒的时间才能转变为Forwarding状态。
保持PCA ping PCB,断开PCA或PCB的连接,然后再恢复连接,则两台主机需要等待默认30秒的时间才能ping通对方。
配置SWB的端口E1/0/1为边缘端口
在端口视图通过命令stp edge-port enable可以将端口设置为边缘端口。配置边缘端口之前需要确认该端口连接的设备为终端设备而非交换机。
配置SWB的端口E1/0/1为边缘端口:
[SWB-Ethernet1/0/1]stp edged-port enable
配置SWC的端口E1/0/1为边缘端口
[SWC-Ethernet1/0/1]stp edged-port enable
再次进行测试。保持PCA ping PCB,断开PCA或PCB的连接,然后再恢复连接,可以发现两台主机立即可以ping通对方。即边缘端口可以立即进入Forwarding状态。
 楼主| 发表于 2013-10-25 14:59:21 | 显示全部楼层
MSTP
MSTP的配置
在交换机上配置MSTP
例如,SWA的相关配置如下
[SWA]stp mode mstp
[SWA] stp region-configuration
[SWA-mst-region] region-name example
[SWA-mst-region] instance 2 vlan 2
[SWA-mst-region] instance 3 vlan 3
[SWA-mst-region] instance 4 vlan 4
[SWA-mst-region] revision-level 0
[SWA-mst-region] active region-configuration
其中配置了三个MST实例,instance2、instance3和instance4,并分别将VLAN2、VLAN3、VLAN4映射到这三个MST实例。
在SWA上创建VLAN2、VLAN3和VLAN4。
[SWA]vlan 2 to 4
Please wait... Done.
将互联端口配置为Trunk端口,并允许VLAN1、VLAN 2、VLAN3、VLAN4通过。
[SWA-Ethernet1/0/22]port link-type trunk
[SWA-Ethernet1/0/22]port trunk permit vlan 1 to 4
Please wait... Done.
[SWA-Ethernet1/0/23]port link-type trunk
[SWA-Ethernet1/0/23]port trunk permit vlan 1 to 4
Please wait... Done.
[SWA-Ethernet1/0/23]port link-type trunk
[SWA-Ethernet1/0/23]port trunk permit vlan 1 to 4
Please wait... Done.

其他交换机进行相同的配置。
将SWC和SWD连接PC机的端口E1/0/1配置为边缘端口,并将端口加入VLAN2。
[SWC-Ethernet1/0/1]stp edged-port enable
[SWC-Ethernet1/0/1]port access vlan 2

[SWD-Ethernet1/0/1]stp edged-port enable
[SWD-Ethernet1/0/1]port access vlan 2
查看网络中的根桥
通过display stp root可以查看网络中的根桥。假设SWA的根桥ID最小,则此时SWA为网络中的根桥。
<SWA>display stp root
MSTID  Root Bridge ID        ExtPathCost IntPathCost Root Port
   0    32768.000f-e23d-59f0  0           0                                       
   2    32768.000f-e23d-59f0  0           0                                       
   3    32768.000f-e23d-59f0  0           0                                       
   4    32768.000f-e23d-59f0  0           0  
可以看到由于没有为各MST实例指定不同的根桥,此时所有实例的根桥均为SWA。
查看各交换机端口的STP状态和角色
通过display stp brief可以查看交换机各端口的STP状态和角色。
例如,查看SWA的端口角色如下:
<SWA>display stp brief
MSTID      Port                         Role  STP State     Protection
   0        Ethernet1/0/22              DESI  FORWARDING    NONE
   0        Ethernet1/0/23              DESI  FORWARDING    NONE
   0        Ethernet1/0/24              DESI  FORWARDING    NONE
   2        Ethernet1/0/22              DESI  FORWARDING    NONE
   2        Ethernet1/0/23              DESI  FORWARDING    NONE
   2        Ethernet1/0/24              DESI  FORWARDING    NONE
   3        Ethernet1/0/22              DESI  FORWARDING    NONE
   3        Ethernet1/0/23              DESI  FORWARDING    NONE
   3        Ethernet1/0/24              DESI  FORWARDING    NONE
   4        Ethernet1/0/22              DESI  FORWARDING    NONE
   4        Ethernet1/0/23              DESI  FORWARDING    NONE
   4        Ethernet1/0/24              DESI  FORWARDING    NONE
可以看到,由于SWA在所有实例中均为根桥,所以SWA的端口在所有实例中的角色都相同,均为指定端口。
查看SWD的端口信息如下:
<SWD>display stp brief
MSTID      Port                         Role  STP State     Protection
   0        Ethernet1/0/1                DESI  FORWARDING    NONE
   0        Ethernet1/0/22               ALTE  DISCARDING    NONE
   0        Ethernet1/0/23               ROOT  FORWARDING    NONE
   0        Ethernet1/0/24               ALTE  DISCARDING    NONE
   2        Ethernet1/0/1                DESI  FORWARDING    NONE
   2        Ethernet1/0/22               ALTE  DISCARDING    NONE
   2        Ethernet1/0/23               ROOT  FORWARDING    NONE
   2        Ethernet1/0/24               ALTE  DISCARDING    NONE
   3        Ethernet1/0/22               ALTE  DISCARDING    NONE
   3        Ethernet1/0/23               ROOT  FORWARDING    NONE
   3        Ethernet1/0/24               ALTE  DISCARDING    NONE
   4        Ethernet1/0/22               ALTE  DISCARDING    NONE
   4        Ethernet1/0/23               ROOT  FORWARDING    NONE
   4        Ethernet1/0/24               ALTE  DISCARDING    NONE
可以看到SWD的端口在所有实例中的角色也相同。
为不同实例指定不同的首选根桥和备份根桥
通过命令stp instance instance-id root primary和stp instance instance-id root secondary为不同实例指定不同的首选根桥和备份根桥。
指定SWB为MSTI实例2的首选根桥,SWC为MSTI实例3的首选根桥,SWD为MSTI实例4的首选根桥。
[SWB]stp instance 2 root primary
[SWC]stp instance 3 root primary
[SWD]stp instance 4 root primary
查看当前各实例的根桥
通过display stp可以查看各实例的根桥信息。
例如,在SWD上查看根桥,信息显式如下:
[SWD]display stp root
MSTID  Root Bridge ID        ExtPathCost IntPathCost Root Port
   0    32768.000f-e23d-59f0 0              200         Ethernet1/0/23              
   2    0.000f-e245-6bc0      0              200         Ethernet1/0/24              
   3    0.000f-e23e-f9b0      0              200         Ethernet1/0/22              
   4    0.000f-e24a-df50      0              0                                       
可以看到对于MST实例0,SWD连接SWA的端口为根端口,通过查看MAC地址可以确认SWA为MST实例0的根桥;对于MST实例2,SWD连接SWB的端口为根端口,根桥为SWB;对于MST实例3,SWD连接SWC的端口为根端口,根桥为SWC;对于MST实例4,SWD即为根桥。
查看当前各交换机端口的STP状态和角色
通过命令display stp brief可以查看当前交换机端口的角色和状态。
例如,在SWD上查看端口STP角色和状态,信息如下:
[SWD]display stp brief
MSTID      Port                         Role  STP State     Protection
   0        Ethernet1/0/1                DESI  DISCARDING    NONE
   0        Ethernet1/0/22               ALTE  DISCARDING    NONE
   0        Ethernet1/0/23               ROOT  FORWARDING    NONE
   0        Ethernet1/0/24               ALTE  DISCARDING    NONE
   2        Ethernet1/0/1                DESI  DISCARDING    NONE
   2        Ethernet1/0/22               ALTE  DISCARDING    NONE
   2        Ethernet1/0/23               ALTE  DISCARDING    NONE
   2        Ethernet1/0/24               ROOT  FORWARDING    NONE
   3        Ethernet1/0/22               ROOT  FORWARDING    NONE
   3        Ethernet1/0/23               ALTE  DISCARDING    NONE
   3        Ethernet1/0/24               ALTE  DISCARDING    NONE
   4        Ethernet1/0/22               DESI  FORWARDING    NONE
   4        Ethernet1/0/23               DESI  FORWARDING    NONE
   4        Ethernet1/0/24               DESI  FORWARDING    NONE
可以看到,由于为不同实例指定了不同的根桥,导致端口在不同的实例具有不同的角色并处于不同的状态。VLAN2、VLAN3、VLAN4的数据流将走不同的路径,从而实现了不同VLAN数据流量的负载分担。
查看STP详细信息
通过display stp 可以查看STP详细信息。例如查看SWD的STP详细信息如下:
[SWD]display stp
-------[CIST Global Info][Mode MSTP]-------
CIST Bridge         :32768.000f-e24a-df50
Bridge Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC      :32768.000f-e23d-59f0 / 0
CIST RegRoot/IRPC   :32768.000f-e23d-59f0 / 200
CIST RootPortId     :128.23
BPDU-Protection     :disabled
Bridge Config-            
Digest-Snooping     :disabled
TC or TCN received  :166
Time since last TC  :0 days 0h:3m:18s
----[Port1(Ethernet1/0/1)][FORWARDING]----
Port Protocol       :enabled
Port Role           :CIST Designated Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e24a-df50 / 128.1
Port Edged          :Config=disabled / Active=disabled
Point-to-point      :Config=auto / Active=true
Transmit Limit      :10 packets/hello-time
Protection Type     :None
MST BPDU Format     :Config=auto / Active=legacy
Port Config-            
Digest-Snooping     :disabled
Rapid transition    :false
Num of Vlans Mapped :0
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 0s RemHop 19
BPDU Sent           :118            
          TCN: 0, Config: 0, RST: 0, MST: 118
BPDU Received       :0            
          TCN: 0, Config: 0, RST: 0, MST: 0
……
----[Port22(Ethernet1/0/22)][DISCARDING]----
Port Protocol       :enabled
Port Role           :CIST Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e23e-f9b0 / 128.22
Port Edged          :Config=disabled / Active=disabled
Point-to-point      :Config=auto / Active=true
Transmit Limit      :10 packets/hello-time
Protection Type     :None
MST BPDU Format     :Config=auto / Active=legacy
Port Config-            
Digest-Snooping     :disabled
Num of Vlans Mapped :1
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 0s RemHop 19
BPDU Sent           :571            
          TCN: 0, Config: 0, RST: 0, MST: 571
BPDU Received       :33680            
          TCN: 0, Config: 0, RST: 0, MST: 33680

----[Port23(Ethernet1/0/23)][FORWARDING]----
Port Protocol       :enabled
Port Role           :CIST Root Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e23d-59f0 / 128.26
Port Edged          :Config=disabled / Active=disabled
Point-to-point      :Config=auto / Active=true
Transmit Limit      :10 packets/hello-time
Protection Type     :None
MST BPDU Format     :Config=auto / Active=legacy
Port Config-            
Digest-Snooping     :disabled
Num of Vlans Mapped :1
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 0s RemHop 20
BPDU Sent           :941            
          TCN: 0, Config: 0, RST: 93, MST: 848
BPDU Received       :33833            
          TCN: 0, Config: 0, RST: 6, MST: 33827

----[Port24(Ethernet1/0/24)][DISCARDING]----
Port Protocol       :enabled
Port Role           :CIST Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e245-6bc0 / 128.24
Port Edged          :Config=disabled / Active=disabled
Point-to-point      :Config=auto / Active=true
Transmit Limit      :10 packets/hello-time
Protection Type     :None
MST BPDU Format     :Config=auto / Active=legacy
Port Config-            
Digest-Snooping     :disabled
Num of Vlans Mapped :1
PortTimes           :Hello 2s MaxAge 20s FwDly 15s MsgAge 0s RemHop 19
BPDU Sent           :860            
          TCN: 0, Config: 0, RST: 51, MST: 809
BPDU Received       :33844            
          TCN: 0, Config: 0, RST: 3, MST: 33841
……

-------[MSTI 2 Global Info]-------
MSTI Bridge ID      :32768.000f-e24a-df50
MSTI RegRoot/IRPC   :0.000f-e245-6bc0 / 200
MSTI RootPortId     :128.24
Master Bridge       :32768.000f-e23d-59f0
Cost to Master      :200
TC received         :96

----[Port1(Ethernet1/0/1)][FORWARDING]----
Port Role           esignated Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e24a-df50 / 128.1
Rapid transition    :false
Num of Vlans Mapped :1
Port Times          :RemHops 19

----[Port22(Ethernet1/0/22)][DISCARDING]----
Port Role           :Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e23e-f9b0 / 128.22
Num of Vlans Mapped :1
Port Times          :RemHops 19

----[Port23(Ethernet1/0/23)][DISCARDING]----
Port Role           :Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e23d-59f0 / 128.26
Num of Vlans Mapped :1
Port Times          :RemHops 19

----[Port24(Ethernet1/0/24)][FORWARDING]----
Port Role           :Root Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :0.000f-e245-6bc0 / 128.24
Num of Vlans Mapped :1
Port Times          :RemHops 20

-------[MSTI 3 Global Info]-------
MSTI Bridge ID      :32768.000f-e24a-df50
MSTI RegRoot/IRPC   :0.000f-e23e-f9b0 / 200
MSTI RootPortId     :128.22
Master Bridge       :32768.000f-e23d-59f0
Cost to Master      :200
TC received         :80

----[Port22(Ethernet1/0/22)][FORWARDING]----
Port Role           :Root Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :0.000f-e23e-f9b0 / 128.22
Num of Vlans Mapped :1
Port Times          :RemHops 20

----[Port23(Ethernet1/0/23)][DISCARDING]----
Port Role           :Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e23d-59f0 / 128.26
Num of Vlans Mapped :1
Port Times          :RemHops 19

----[Port24(Ethernet1/0/24)][DISCARDING]----
Port Role           :Alternate Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :32768.000f-e245-6bc0 / 128.24
Num of Vlans Mapped :1
Port Times          :RemHops 19

-------[MSTI 4 Global Info]-------
MSTI Bridge ID      :0.000f-e24a-df50
MSTI RegRoot/IRPC   :0.000f-e24a-df50 / 0
MSTI RootPortId     :0.0
MSTI Root Type      RIMARY root
Master Bridge       :32768.000f-e23d-59f0
Cost to Master      :200
TC received         :66

----[Port22(Ethernet1/0/22)][FORWARDING]----
Port Role           esignated Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :0.000f-e24a-df50 / 128.22
Rapid transition    :true
Num of Vlans Mapped :1
Port Times          :RemHops 20

----[Port23(Ethernet1/0/23)][FORWARDING]----
Port Role           esignated Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :0.000f-e24a-df50 / 128.23
Rapid transition    :true
Num of Vlans Mapped :1
Port Times          :RemHops 20

----[Port24(Ethernet1/0/24)][FORWARDING]----
Port Role           esignated Port
Port Priority       :128
Port Cost(Legacy)   :Config=auto / Active=200
Desg. Bridge/Port   :0.000f-e24a-df50 / 128.24
Rapid transition    :true
Num of Vlans Mapped :1
Port Times          :RemHops 20
其中包含CIST参数以及每一个MST实例的参数。
CIST的参数包含CIST总根、外部路径开销、IST根桥、内部路径开销、CIST根端口等信息。
MST实例的参数包含全局参数和端口参数。全局参数包含域根桥ID、Master桥ID、域根端口ID和到达域根的路径开销值等信息。端口参数包含端口在该实例中的端口角色、端口优先级、指定端口等信息。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-16 08:18 , Processed in 0.171600 second(s), 25 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表