网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 5849|回复: 22

以太网交换基础

[复制链接]
发表于 2013-8-5 15:27:08 | 显示全部楼层 |阅读模式
以太网交换基础
MAC地址学习
本实验的主要任务是学员掌握MAC地址学习机制以及理解MAC地址表
运行超级终端并初始化交换机配置
将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
连接PC并查看MAC地址表
按照实验组网图先将PCA与交换机连接,然后在交换机上通过display mac-address命令查看地址表项;然后再将PCB与交换机连接,再次在交换机上通过display mac-address命令查看地址表项。然后根据此输出结果完成补充如下表格:
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
00-11-43-51-C5-A7        1        LEARNED        Ethernet1/0/1        AGING
00-10-5C-E5-F4-80        1        LEARNED        Ethernet1/0/11        AGING
从如上表格中可以看到,MAC地址对应的port index表示
该MAC地址对应的二层以太网端口,也即表示该MAC地址是从该端口学习到的,那么同时发往该MAC地址的报文将从此端口发出
那么此时,如果PCA要给PCB发送一个数据帧,其转发流程为
由于在SWA的MAC地址表汇中已经有PCA、PCB的MAC地址表项记录,因此PCA发送给PCB的数据包,会直接查询SWA上的MAC地址表项,根据该表项记录的PCB对应的端口号,直接将数据帧转到该端口,不再向其他端口转发数据帧
配置静态MAC地址
在交换机上将PCA的MAC地址配置为静态MAC地址表项,请在如下空格中补充完整的配置命令:
[SWA]mac-address static 0011-4351-C5A7 interface Ethernet 1/0/1 vlan 1
配置完成后,在SWA上查看MAC地址表项,可以看到PCA的MAC地址表项中State项为Config static,Aging time项为NOAGED,port index项为 Ethernet1/0/1
此时将PCA连接SWA的网线断开,将PCA连接到SWA的Ethernet 1/0/15端口上,然后再次在SWA上查看MAC地址表项,此时看到的地址表项State项为Config static,Aging time项为NOAGED,port index项为Ethernet1/0/1;可以看到SWA的MAC地址没有学习到端口Ethernet1/0/15上,造成这种情况的原因是交换机的MAC地址表中对于同一个MAC地址同一VLAN中只有一个记录,如果静态配置了PCA的MAC地址和端口好的映射关系以后,交换机就不能也不再在同一VLAN中动态学习这个主机的MAC地址了。
 楼主| 发表于 2013-8-6 15:47:15 | 显示全部楼层
IPv6基础
IPv6地址配置及查看
建立物理连接
按照拓扑进行连接,并检查路由器的软件版本及配置信息,确保路由器软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户模式下擦除设备中的配置文件,然后重启路由器以使系统采用缺省的配置参数进行初始化。
以上步骤可能会用到以下命令:
<RTA> display version
<RTA> reset saved-configuration
<RTA> reboot
配置接口自动生成链路本地地址及测试可达性,查看邻居信息
请在路由器RTA和RTB的系统视图下,使能路由器的IPv6报文转发功能,并在下面的空格中写出完整的命令。
   __ipv6_________
然后在路由器G0/0接口视图下,配置接口自动生成链路本地地址,并在下面的空格中写出完整的命令。
RTA上的命令:___[RTA-GigabitEthernet0/0]ipv6 address auto link-local_____
RTB上的命令:___[RTB-GigabitEthernet0/0]ipv6 address auto link-local_____
以上配置完成后,路由器会自动生成前缀为FE80::的链路本地地址。请用命令来查看生成的链路本地地址,并在下面的空格中写出完整的命令。
   ____display ipv6 interface GigabitEthernet 0/0_______________
请在下面填入所看到的地址。
RTA的接口G0/0链路本地地址是:_____ FE80::20F:E2FF:FED1:BDF8_____
RTB的接口G0/0链路本地地址是:_____ FE80::20F:E2FF:FED1:BFB8_____

说明:
链路本地地址和MAC地址相关,每台设备会有所不同。
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ______ ping ipv6 FE80::20F:E2FF:FED1:BFB8 -i GigabitEthernet 0/0___
可达性测试的结果是: 成功 □ 失败 □
如果可达性测试失败,请分析原因。
在RTA和RTB上通过命令来查看路由器的邻居信息,并在下面的空格中写出完整的命令。
   ______ display ipv6 neighbors all_________
RTA上看到的邻居地址信息是:_____ FE80::20F:E2FF:FED1:BFB8 _____
RTB的看到的邻居地址信息是:_____ FE80::20F:E2FF:FED1:BDF8_____
配置接口生成EUI-64地址并测试可达性,查看邻居信息
请在RTA及RTB的G0/0接口视图下,配置接口生成符合EUI-64格式的全球单播地址,并设定其前缀为1::/64。在下面的空格中写出完整的命令。
RTA上的命令:_________ ipv6 address 1::/64 eui-64_______
RTB上的命令:_________ ipv6 address 1::/64 eui-64__________
以上配置完成后,路由器接口会生成符合EUI-64规范的全球单播地址。用命令来查看生成的EUI-64地址并测试可达性。请在下面填入实验结果:
RTA的接口G0/0全球单播地址是:_________ 1::20F:E2FF:FED1:BDF8______
RTB的接口G0/0全球单播地址是:_________ 1::20F:E2FF:FED1:BFB8_______
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ________ping ipv6 1::20F:E2FF:FED1:BFB8__________
可达性测试的结果是: 成功 □ 失败 □
在RTA和RTB上通过命令来查看路由器的邻居信息。
RTA上看到的邻居地址信息是:
_1::20F:E2FF:FED1:BFB8,FE80::20F:E2FF:FED1:BFB8__
RTB的看到的邻居地址信息是:
_1::20F:E2FF:FED1:BDF8,FE80::20F:E2FF:FED1:BDF8__
配置接口生成全球单播地址并测试可达性,查看邻居信息
请在RTA及RTB的G0/0接口视图下,分别配置全球单播地址2::1/64及2::2/64,并在下面的空格中写出完整的命令。
RTA上的命令:____ [RTA-GigabitEthernet0/0]ipv6 address 2::1/64______
RTB上的命令:_____ [RTB-GigabitEthernet0/0]ipv6 address 2::2/64_____
以上配置完成后,路由器接口会生成全球单播地址。用命令display ipv6 interface g0/0 verbose来查看全球单播地址。请在下面填入实验结果:
RTA的接口G0/0全球单播地址是:________2::1/64_______________
RTB的接口G0/0全球单播地址是:________ 2::2/64______________
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ________<RTA>ping ipv6 2::2_______________
可达性测试的结果是: 成功 □ 失败 □
在RTA和RTB上通过命令来查看路由器的邻居信息。
RTA上看到的邻居地址信息是:______1::20F:E2FF:FED1:BFB8,FE80::20F:E2FF:FED1:BFB8,2::2____
RTB的看到的邻居地址信息是:___1::20F:E2FF:FED1:BDF8,FE80::20F:E2FF:FED1:BDF8,2::1____
 楼主| 发表于 2013-8-6 15:48:57 | 显示全部楼层
以太网交换基础
MAC地址学习
本实验的主要任务是学员掌握MAC地址学习机制以及理解MAC地址表
运行超级终端并初始化交换机配置
将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
连接PC并查看MAC地址表
按照实验组网图先将PCA与交换机连接,然后在交换机上通过display mac-address命令查看地址表项;然后再将PCB与交换机连接,再次在交换机上通过display mac-address命令查看地址表项。然后根据此输出结果完成补充如下表格:
MAC ADDR        VLAN ID        STATE        PORT INDEX        AGING TIME(s)
00-11-43-51-C5-A7        1        LEARNED        Ethernet1/0/1        AGING
00-10-5C-E5-F4-80        1        LEARNED        Ethernet1/0/11        AGING
从如上表格中可以看到,MAC地址对应的port index表示
该MAC地址对应的二层以太网端口,也即表示该MAC地址是从该端口学习到的,那么同时发往该MAC地址的报文将从此端口发出
那么此时,如果PCA要给PCB发送一个数据帧,其转发流程为
由于在SWA的MAC地址表汇中已经有PCA、PCB的MAC地址表项记录,因此PCA发送给PCB的数据包,会直接查询SWA上的MAC地址表项,根据该表项记录的PCB对应的端口号,直接将数据帧转到该端口,不再向其他端口转发数据帧
配置静态MAC地址
在交换机上将PCA的MAC地址配置为静态MAC地址表项,请在如下空格中补充完整的配置命令:
[SWA]mac-address static 0011-4351-C5A7 interface Ethernet 1/0/1 vlan 1
配置完成后,在SWA上查看MAC地址表项,可以看到PCA的MAC地址表项中State项为Config static,Aging time项为NOAGED,port index项为 Ethernet1/0/1
此时将PCA连接SWA的网线断开,将PCA连接到SWA的Ethernet 1/0/15端口上,然后再次在SWA上查看MAC地址表项,此时看到的地址表项State项为Config static,Aging time项为NOAGED,port index项为Ethernet1/0/1;可以看到SWA的MAC地址没有学习到端口Ethernet1/0/15上,造成这种情况的原因是交换机的MAC地址表中对于同一个MAC地址同一VLAN中只有一个记录,如果静态配置了PCA的MAC地址和端口好的映射关系以后,交换机就不能也不再在同一VLAN中动态学习这个主机的MAC地址了。
 楼主| 发表于 2013-8-7 14:58:40 | 显示全部楼层
VLAN
配置Access链路端口
本实验任务通过在交换机上配置Access链路端口而使PC处于不同VLAN,隔离PC间的访问,从而使学员加深对Access链路端口的理解。
建立物理连接并运行超级终端
将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接交换机的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
观察缺省VLAN
可以在任意视图下通过display vlan命令查看交换机上的VLAN相关信息。
从以上输出可知,交换机上的缺省VLAN是1。
请执行合适的命令以查看缺省VLAN的信息,并在下面的空格中写出完整的命令
   display vlan 1
配置VLAN并添加端口
  分别在SWA和SWB上创建VLAN 2,并将PCA和PCC所连接的端口Ethernet1/0/1添加到VLAN 2中。
配置SWA:
  请执行合适的命令在SWA上创建VLAN 2并将端口Ethernet1/0/1添加到VLAN 2中,在下面的空格中写出完整的命令:
[SWA]vlan 2
[SWA-vlan2]port Ethernet 1/0/1
配置SWB:
  请执行合适的命令创建VLAN 2并将端口Ethernet1/0/1添加到VLAN 2中,在下面的空格中写出完整的命令:
[SWB]vlan 2
[SWB-vlan2]port Ethernet 1/0/1
在交换机上查看有关VLAN以及VLAN 2的信息:
在SWA上查看配置的Vlan信息,请在下面空格中填写完整的命令:
[SWA]display vlan
在SWA上查看VLAN 2的信息,请在下面空格中填写完整的命令:  
[SWA]display vlan 2
查看物理端口链路类型
  请执行合适的命令查看交换机的物理端口Ethernet1/0/1的信息,在下面的空格中写出完整命令:
[SWA]display interface Ethernet 1/0/1
  执行上述命令,从命令的输出信息中可以发现,端口Ethernet1/0/1的PVID是2,端口Ethernet1/0/1的链路类型是access,该端口Tagged   VLAN ID是 none,该端口Untagged VLAN ID是2
测试VLAN间的隔离
我们在PC上配置IP地址,通过Ping命令来测试处于不同VLAN间的PC能否互通。
IP地址列表
  设备名称          IP地址          网关
  PCA          172.16.0.1/24          --
  PCB          172.16.0.2/24          --
  PCC          172.16.0.3/24          --
  PCD          172.16.0.4/24          --
按表15-1所示在PC上配置IP地址。
  配置完成后,在PCA上用Ping命令来测试到其它PC的互通性。其结果应该是PCA与PCB 不能(能/不能)互通,PCC和PCD不能(能/不能)互通。
配置Trunk链路端口
  本实验是在交换机间配置Trunk链路端口,使同一VLAN中的PC能够跨交换机访问。通过本实验,学员应该能够掌握Trunk链路端口的配置及作用。
跨交换机VLAN互通测试
  在上个实验中,PCA和PCC表面上都属于VLAN 2,从整个网络环境考虑,它们并不在一个广播域,即本质上不在一个VLAN中,因为两个交换机上的VLAN目前只是各自在本机起作用,还没有发生关联。在PCA上用Ping命令来测试与PCC能否互通。其结果应该是不能互通。
  PCA与PCC之间不能互通。因为交换机之间的端口Ethernet 1/0/24是Access链路端口,且属于VLAN 1,不允许VLAN 2的数据帧通过。
配置Trunk链路端口
  在SWA和SWB上配置端口Ethernet 1/0/24为Trunk链路端口并设置允许需要的VLAN数据帧通过。
配置SWA上端口Ethernet 1/0/24的Trunk相关属性:
[SWA]interface Ethernet 1/0/24
[SWA-Ethernet1/0/24]port link-type trunk
请在如上空格中补充完整的配置命令并说明该配置命令的含义:
如上命令设置端口的Ethernet 1/0/24链路类型为Trunk类型
[SWA-Ethernet1/0/24]port trunk permit vlan all
请在空格处说明该配置命令的含义:
如上配置命令配置允许所有的VLAN通过当前Trunk端口
完成SWB上端口Ethernet 1/0/24的Trunk相关配置,请在下面空格中填写完整的命令:
[SWB]interface Ethernet 1/0/24
[SWB-Ethernet1/0/24]port link-type trunk
[SWB-Ethernet1/0/24]port trunk permit vlan all
查看Trunk相关信息
  在SWA上执行display interface Ethernet 1/0/24命令可以查看端口Ethernet 1/0/24的信息,通过执行该命令后的输出的信息显示可以看到,端口的PVID值是1,端口类型是trunk,允许 VLAN 1~4094(VLAN号)通过
  在SWA上执行display vlan 2命令可以查看VLAN 2的相关信息,通过执行该命令后的输出的信息显示可以看到VLAN 2 中包含了端口Ethernet 1/0/24,且数据帧是以tagged(tagged/untagged)的形式通过端口的。
跨交换机VLAN互通测试
在PCA上用Ping命令来测试与PCC能否互通。其结果应该是可以互通
 楼主| 发表于 2013-8-7 14:59:37 | 显示全部楼层
配置Hybrid链路端口
  本实验任务是利用Hybrid端口的特性――一个端口可以属于多个不同的VLAN,来完成分属不同VLAN内的同网段PC机的访问需求.通过本实验,学员应该能够掌握Hybrid链路端口的配置及作用。
配置PC属于不同的VLAN
  保持实验一中配置的PC的IP地址不变,在实验二的基础上,修改PCA、PCB、PCC、PCD分别属于VLAN 10、VLAN 20、VLAN 30、VLAN 40,同时保持设置端口Ethernet 1/0/24为Trunk链路端口并设置允许所有的VLAN数据帧通过。然后在PC上使用PING测试PCA、PCB、PCC、PCD之间的互通性,发现四台PC之间不能互通(能/不能)
然后在SWA、SWB上增加如下配置:
[SWA]vlan 30
[SWA]vlan 40
[SWB]vlan 10
[SWB]vlan 20
  如上配置命令的作用是为后面配置hybrid属性做准备,因为只有在本机存在的VLAN,在配置端口hybrid属性时才能配置该VLAN的tagged或者untagged属性。
配置Hybrid链路端口
  在SWA上配置PCA所连接的端口Ethernet 1/0/1为Hybrid端口,并允许VLAN 30、VLAN 40的报文以untagged方式通过:
[SwitchA]interface Ethernet1/0/1
[SwitchA-Ethernet0/1]port link-type hybrid
请在如上空格中补充完整的配置命令并说明该配置命令的含义:
设置端口Ethernet 1/0/1的链路类型为Hybrid类型
[SwitchA-Ethernet0/1]port hybrid vlan  30  40 untagged
请在空格处说明该配置命令的含义:
  端口Ethernet 1/0/1能够接收VLAN 30和40发过来的报文并且发送这些VLAN的报文时不带VLAN标签
  在SWA上配置PCB所连接的端口Ethernet 1/0/2为Hybrid端口,并允许VLAN 30、VLAN 40的报文以untagged方式通过,请在下面空格中填写完整的命令:
[SwitchA]interface Ethernet 1/0/2[SwitchA-Ethernet0/2]port link-type hybrid[SwitchA-Ethernet0/2]port hybrid vlan 30 40 untagged
  在SWB上配置PCC所连接的端口Ethernet 1/0/1为Hybrid端口,并允许VLAN 10、VLAN 20、VLAN 40的报文以untagged方式通过,请在下面空格中填写完整的命令:
[SwitchB]interface Ethernet 1/0/1[SwitchB-Ethernet0/1]port link-type hybrid[SwitchB-Ethernet0/1]port hybrid vlan 10 20 40 untagged
  在SWB上配置PCD所连接的端口Ethernet 1/0/2为Hybrid端口,并允许VLAN 10、VLAN 20、VLAN 30的报文以untagged方式通过,请在下面空格中填写完整的命令:
[SwitchB]interface Ethernet 1/0/2[SwitchB-Ethernet0/2]port link-type hybrid[SwitchB-Ethernet0/2]port hybrid vlan 10 20 30 untagged
查看Hybrid相关信息
  在SWA上执行display vlan 10命令可以查看VLAN 10的相关信息,通过执行该命令后的输出的信息显示可以看到VLAN 10中tagged的端口为Ethernet1/0/24, untagged的端口为Ethernet1/0/1
  在SWA上执行display vlan 20命令可以查看VLAN 20的相关信息,通过执行该命令后的输出的信息显示可以看到VLAN 20中tagged的端口为Ethernet1/0/24, untagged的端口为Ethernet1/0/2
  在SWA上执行display vlan 30命令可以查看VLAN 30的相关信息,通过执行该命令后的输出的信息显示可以看到VLAN 30中tagged的端口为Ethernet1/0/24, untagged的端口为Ethernet1/0/1、Ethernet1/0/2
  在SWA上执行display vlan 40命令可以查看VLAN 40的相关信息,通过执行该命令后的输出的信息显示可以看到VLAN 40中tagged的端口为Ethernet1/0/24, untagged的端口为Ethernet1/0/1、Ethernet1/0/2。
  在SWB上执行如上同样的命令查看相关的VLAN信息
  在SWA上执行display interface ethernet 1/0/1命令可以查看端口Ethernet 1/0/1的信息,通过执行该命令后的输出的信息显示可以看到,端口的PVID值是10,端口类型是hybrid,Tagged VLAN ID号是none,  Untagged VLAN ID号是 10、30、40
  在SWA上执行display interface ethernet 1/0/2命令可以查看端口Ethernet 1/0/2的信息,通过执行该命令后的输出的信息显示可以看到,端口的PVID值是20,端口类型是hybrid,Tagged VLAN ID号是none,  Untagged VLAN ID号是 20、30、40
  在SWB上执行display interface ethernet 1/0/1命令可以查看端口Ethernet 1/0/1的信息,通过执行该命令后的输出的信息显示可以看到,端口的PVID值是30,端口类型是hybrid,Tagged VLAN ID号是none,  Untagged VLAN ID号是 10、20、30、40
  在SWB上执行display interface ethernet 1/0/2命令可以查看端口Ethernet 1/0/2的信息,通过执行该命令后的输出的信息显示可以看到,端口的PVID值是40,端口类型是hybrid,Tagged VLAN ID号是none,  Untagged VLAN ID号是 10、20、30、40
检查不同VLAN之间的互通性
  完成步骤三的配置后,在PC上通过PING检测PC之间的互通性,检查发现:
PCA和PCB不能互通
PCA和PCC可以互通
PCA和PCD 可以互通
PCB和PCC 可以互通
PCB和PCD 可以互通
PCC和PCD 可以互通  
 楼主| 发表于 2013-8-7 15:00:42 | 显示全部楼层
生成树协议
STP基本配置
连接配置电缆
配置STP
配置SWA:
在系统视图下启动STP,
[SWA]stp enable
然后完成了如下配置命令:
[SWA]stp priority 0
如上配置命令的含义和作用是:设置SWA的优先级为0,以使SWA为根桥
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1] stp edged-port enable
如上配置命令的含义是:配置连接PC的端口为边缘端口
配置SWB:
在SWB上启动STP并设置SWB的优先级为4096;并且配置SWB连接PC的端口为边缘端口。请下面的空格中写出完整的配置命令:
[SWB]stp enable
[SWB]stp priority 4096
[SWB]interface Ethernet 1/0/1
[SWB-Ethernet1/0/1] stp edged-port enable
查看STP信息
在SWA上执行display stp命令查看STP信息,执行display stp brief命令查看STP简要信息,依据该命令输出的信息,可以看到SWA上所有端口的STP角色是DESI即角色为指定端口,都处于FORWARDING转发状态
在SWB上执行display stp命令查看STP信息,执行display stp brief命令查看STP简要信息,依据该命令输出的信息,可以看到SWB端口E1/0/23的STP角色是根端口,处于FORWARDING转发状态,端口E1/0/24的STP角色是备份根端口,处于DISCARDING阻塞状态;连接PC的端口E1/0/1STP角色是指定端口,处于转发状态
从上可以得知,STP能够发现网络中的环路,并有选择的对某些端口进行阻塞,最终将环路网络结构修剪成无环路的树型网络结构
STP冗余特性验证
分别配置PCA、PCB的IP地址为172.16.0.1/24、172.16.0.2/24,配置完成后,在PCA上执行命令“Ping 172.16.0.2 –t”,以使PCA向PCB不间断发送ICMP报文
然后依据步骤三查看的SWB上看STP端口状态,确定交换机间端口E1/0/23处于转发状态。在SWB上将交换机之间处于STP转发状态端口的电缆断开,然后再次在SWB上查看STP端口状态,查看发现SWB端口E1/0/24处于转发状态。
通过如上操作以及显示信息可以看出,STP不但能够阻断冗余链路,并且能够在活动链路断开时,通过激活被阻断的冗余链路而恢复网络的连通。
端口状态迁移查看
在交换机SWA上断开端口E1/0/1的电缆,再重新连接,并且在SWA上查看交换机输出信息。如下:
[SWA]
……
Ethernet1/0/1: link status is UP
%Apr 26 14:04:53:880 2000 SWA MSTP/2/PFWD:Instance 0's Ethernet1/0/1 has been set to forwarding state!
可以看到,端口在连接电缆后马上成为转发状态。出现这种情况的原因是因为端口被配置成边缘端口,无须延迟而进入转发状态,这也是RSTP/MSTP相对于STP的改进之一
为了清晰观察端口状态,我们在连接PC的端口E1/0/1上取消边缘端口配置,请在如下空格中填写完整的配置命令:
配置SWA取消边缘端口配置:
[SWA]interface Ethernet 1/0/1
[SWA-Ethernet1/0/1] undo stp edged-port
 配置完成后,断开端口E1/0/1的电缆,再重新连接,并且在SWA上通过命令display stp brief查看端口E1/0/1的状态. 注意每隔几秒钟执行命令查看一次,以能准确看到端口状态的迁移过程. 可知,端口E1/0/1从Discarding状态先迁移到Learning状态,最后到Forwarding状态。从以上实验可知,取消边缘端口配置后,STP收敛速度变慢了
注意:
如果在PCA上Ping 172.16.0.2 –t时出现“Request timed out.”,表明PCB无回应,需要检查PCB是否开启了防火墙或交换机配置是否有问题。
 楼主| 发表于 2013-8-10 15:45:43 | 显示全部楼层
链路聚合
交换机静态链路聚合配置
本实验通过在交换机上配置静态链路聚合,使学员掌握静态链路聚合的配置命令和查看方法。然后通过断开聚合组中的某条链路并观察网络连接是否中断,来加深了解链路聚合所实现的可靠性。
连接配置电缆
将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户模式下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置静态聚合
链路聚合可以分为静态聚合和动态聚合,本实验任务是验证静态聚合
配置SWA,在SWA上完成如下配置:
[SWA] interface bridge-aggregation 1
如上配置命令的含义是:创建二层聚合端口,并进入二层聚合端口视图,数字1表示聚合
组编号为1
[SWA] interface Ethernet 1/0/23
[SWA-Ethernet1/0/23] port link-aggregation group 1
补充如上空格中的配置命令并说明该命令的含义:将端口E1/0/23加入聚合组1
[SWA] interface Ethernet 1/0/24
[SWA-Ethernet1/0/24] port link-aggregation group 1
配置SWB,将端口E1/0/23和端口E1/0/24进行聚合,请在如下空格中补充完整的配置命
令:
[SWB] interface bridge-aggregation 1
[SWB] interface Ethernet 1/0/23
[SWB-Ethernet1/0/23] port link-aggregation group 1
[SWB] interface Ethernet 1/0/24
[SWB-Ethernet1/0/24] port link-aggregation group 1
查看聚合组信息
分别在SWA和SWB上通过display link-aggregation summary命令查看二层聚合端口所对应的聚合组摘要信息,通过display link-aggregation verbose命令查看二层聚合端口所对应聚合组的详细信息
通过执行查看聚合组摘要信息命令,可以得知该聚合组聚合端口类型是:BAGG代表二层聚合端口,聚合模式是S静态聚合,负载分担类型是share为负载分担类型,Select Ports数是2,Unselect Ports数是0。
链路聚合组验证
IP地址列表
设备名称        IP地址        网关
PCA        172.16.0.1/24        --
PCB        172.16.0.2/24        --
按表17-1所示在PC上配置IP地址。
配置完成后,在PCA上执行ping命令,以使PCA向PCB不间断发送ICMP报文。
注意观察交换机面板上的端口LED显示灯,闪烁表明有数据流通过。将聚合组中LED显示灯闪烁的端口上电缆断开,观察PCA上发送的ICMP报文无(有/无)丢失。(注意:丢失一个ping包也属于正常)
如上测试说明聚合组中的两个端口之间是互为备份的关系。
 楼主| 发表于 2013-8-10 15:49:44 | 显示全部楼层
直连路由和静态路由
本实验主要是通过在路由器上查看路由表,观察路由表中路由项。通过本次实验,学员能够掌握如何使用命令来查看路由表,以及了解路由项中要素的含义。
直连路由与路由表查看
建立物理连接并运行超级终端
将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
在路由器上查看路由表
首先,在路由器上在任意视图下通过执行display ip routing-table命令查看路由器全局路由表,执行该命令,从输出信息可知,目前路由器只有目的地址是127.0.0.0/127.0.0.1的路由
IP地址列表
设备名称        接口        IP地址        网关
RTA        S6/0        192.168.1.1/24        --
        G0/0        192.168.0.1/24        --
RTB        S6/0        192.168.1.2/24        --
        G0/0        192.168.2.1/24        --
PCA        --        192.168.0.2/24        192.168.0.1
PCB        --        192.168.2.2/24        192.168.2.1
按表18-1所示在路由器接口上分别配置IP地址。
配置完成后,再次通过display ip routing-table查看RTA路由表,从该命令的输出信息可以看出,路由表中的路由类型为直连路由,这种类型的路由是由链路层协议发现的路由,链路层协议UP后,路由器会将其加入路由表中。如果我们关闭链路层协议,则相关直连路由也消失。
在RTA上通过在接口视图下执行shutdown命令关闭接口GigabitEthernet0/0,然后再次查看RTA路由表,可以看到与该接口网段相关的路由消失(存在/消失)
继续在RTA上在接口视图下执行undo shutdown命令开启接口GigabitEthernet0/0,然后再次查看RTA路由表,可以看到与该接口网段相关的路由存在(存在/消失)
静态路由配置
本实验主要是通过在路由器上配置静态路由,从而达到PC之间能够互访的目的。通过本次实验,学员能够掌握静态路由的配置,加深对路由环路产生原因的理解。
配置PC IP地址
按表18-1所示在PC上配置IP地址和网关。配置完成后,在PC上用Ping命令来测试可达性。
在PCA上测试到网关(192.168.0.1)的可达性,PING的结果是可以互通
在PCA上用Ping命令测试到PCB的可达性,PING的结果是不可达,造成该结果的原因是RTA没有到达PCB(192.168.2.2)的路由
静态路由配置规划
要解决步骤一中出现的PCA与PCB之间可达性的问题,需要规划配置静态路由:
1. 规划RTA上的静态路由,RTA上应该配置一条目的网段为192.168.2.0/24下一跳为192.168.1.2的静态路由
2. 规划RTB上的静态路由,RTB上应该配置一条目的网段为192.168.0.0/24下一跳为192.168.1.1的静态路由
配置静态路由
依据步骤二的规划,在RTA上配置如下静态路由:
[RTA]ip route-static 192.168.2.0 24 192.168.1.2
在RTB上配置如下静态路由:
[RTB]ip route-static 192.168.0.0 24 192.168.1.1
配置完成后,分别在RTA和RTB上查看路由表,可以看到路由表中有一条路由协议类型为static路由优先级为60的静态路由,表明路由配置成功。
再次测试PC之间的可达性,在PCA上用Ping命令测试到PCB的可达性,结果是 PCA与PCB之间可以互通
要查看PCA到PCB得数据报文的传递路径,可以在PCA上通过Tracert命令来查看,查看结果是报文沿PCA→RTA→RTB→PCB的路径被转发的
路由环路观察
为了人为在RTA和RTB之间造成环路,可以在RTA和RTB上分别配置一条缺省路由,该路由的下一跳互相指向对方,因为路由器之间是用串口点到点相连的,所以可以(可以/不可以)配置下一跳为本地接口
在RTA上配置该路由:
[RTA]ip route-static 0.0.0.0 0.0.0.0 s6/0
在RTB上配置该路由:
[RTB]ip route-static 0.0.0.0 0.0.0.0 s6/0
配置完成后,在路由器上查看路由表。
在RTA上查看路由表,可以看到一条优先级为60,协议类型为Static的缺省路由。
在RTB上查看路由表,可以看到一条优先级为60,协议类型为Static的缺省路由
可知,缺省路由配置成功。
然后在PCA上用Tracert命令追踪到目的IP地址3.3.3.3的数据报文的转发路径,由以上输出可以看到,到目的地址3.3.3.3的报文匹配了缺省路由,报文在192.168.1.2和192.168.1.1之间循环转发。造成该现象的原因是:到目的地址3.3.3.3的报文匹配了缺省路由,报文被转发到了RTB(192.168.1.2),而RTB又根据它的缺省路由,把报文转发回了RTA(192.168.1.1)。这样就形成了转发环路,报文在两台路由器之间被循环转发,直到TTL值到0后被丢弃                                                                                                     
 楼主| 发表于 2013-8-10 15:51:03 | 显示全部楼层
RIP
配置RIPv1
本实验主要通过在路由器上配置RIPv1协议,达到PC之间能够互访的目的。通过本次实验,学员应能够掌握RIPv1协议的基本配置。
建立物理连接并运行超级终端
将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
在PC和路由器配置IP地址
IP地址列表
设备名称        接口        IP地址        网关
RTA        S6/0        192.168.1.1/24        --
        G0/0        192.168.0.1/24        --
RTB        S6/0        192.168.1.2/24        --
        G0/0        192.168.2.1/24        --
PCA        --        192.168.0.2/24        192.168.0.1
PCB        --        192.168.2.2/24        192.168.2.1
按表19-2所示在PC上配置IP地址和网关。配置完成后用ping命令测试网络的可达性。
在PCA上用ping命令测试到网关192.168.0.1的可达性,测试结果是 可以互通
在PCA上用ping命令测试到PCB的可达性,测试结果是目的网段不可达,无法互通,产生该结果的原因是 路由器上没有到达目的主机的路由
启用RIP协议
在RTA上配置RIP相关命令如下:
[RTA]rip
如上配置命令的含义是 在RTA上启动RIP进程
[RTA-rip-1]network 192.168.0.0
如上命令提示符中数字1的含义是RIP进程1,在启动RIP的时候,没有指定进程号,就
采用缺省进程1
如上配置命令的含义是在网段192.168.0.0接口上使能RIP
[RTA-rip-1]network 192.168.1.0
在RTB上创建RIP进程并在RTB的两个接口上使能RIP,在如下的空格处填写具体命令:
[RTB]rip
[RTB-rip-1]network 192.168.1.0
[RTB-rip-1]network 192.168.2.0
查看路由表并检测PC之间互通性
完成步骤三后,在路由器上通过display ip routing-table命令查看路由表。
在RTA上可以看到一条目的网段为192.168.2.0/24优先级为100的RIP路由
在RTB上可以看到一条目的网段为192.168.0.0/24优先级为100的RIP路由
在PCA上通过Ping命令检测PC之间的互通性,其结果是可以互通
查看RIP的运行状态
在RTA上通过命令display rip查看RIP运行状态,从其输出信息可知,目前路由器运行的是RIPv1,自动聚合功能是打开(打开/关闭)的;路由更新周期(Update time)是30秒,network命令所指定的网段是192.168.0.0和192.168.1.0。
打开RIP的debugging,观察RIP收发协议报文的情况,看到如下debugging信息:
<RTA>terminal debugging
<RTA>terminal monitor
<RTA>debugging rip 1 packet
<RTA>
*Oct 31 02:20:12:490 2008 RTA RM/6/RMDEBUG: RIP 1 : Sending response on interface GigabitEthernet0/0 from 192.168.0.1 to 255.255.255.255
*Oct 31 02:20:12:490 2008 RTA RM/6/RMDEBUG:   Packet : vers 1, cmd response, length 44
*Oct 31 02:20:12:491 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.1.0, cost 1
*Oct 31 02:20:12:491 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.2.0, cost 2
*Oct 31 02:20:12:491 2008 RTA RM/6/RMDEBUG: RIP 1 : Sending response on interface Serial6/0 from 192.168.1.1 to 255.255.255.255
*Oct 31 02:20:12:491 2008 RTA RM/6/RMDEBUG:   Packet : vers 1, cmd response, length 24
*Oct 31 02:20:12:491 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.0.0, cost 1
*Oct 31 02:20:19:505 2008 RTA RM/6/RMDEBUG: RIP 1 : Receive response from 192.168.1.2 on Serial6/0
*Oct 31 02:20:19:506 2008 RTA RM/6/RMDEBUG:   Packet : vers 1, cmd response, length 24
*Oct 31 02:20:19:506 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.2.0, cost 1
由以上输出可知,RTA在接口GigabitEthernet0/0上发送的路由更新以及在接口Serial6/0上发送的路由更新,目的地址都为255.255.255.255也即是以广播方式发送的.同时可以看到发送以及接收的路由更新网段信息都没有携带掩码。
分析以上的路由更新,可以发现,RTA在接口Serial6/0上收到路由192.168.2.0,而不会再把此路由从接口Serial6/0上发出去。原因是路由器启用RIP后,水平分割功能缺省是打开的
查看水平分割与毒性逆转
在RTA上添加如下配置:
[RTA-Serial6/0]undo rip split-horizon
如上配置命令的含义是在接口Serial 6/0上取消水平分割,配置完成后,看到如下debugging信息:
*Oct 21 09:37:55:171 2008 RTA RM/6/RMDEBUG: RIP 1 : Sending response on interface Serial6/0 from 192.168.1.1 to 255.255.255.255
*Oct 21 09:37:55:171 2008 RTA RM/6/RMDEBUG:   Packet : vers 1, cmd response, length 64
*Oct 21 09:37:55:171 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.0.0, cost 1
*Oct 21 09:37:55:171 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.1.0, cost 1
*Oct 21 09:37:55:172 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.2.0, cost 2
由以上输出可知,在水平分割功能关闭的情况下,RTA在接口Serial6/0上发送的路由更新包含了路由192.168.0.0、192.168.1.0和192.168.2.0。也就是说,路由器把从接口Serial6/0学到的路由192.168.2.0又从该接口发送了出去。这样容易造成路由环路
另外一种避免环路的方法是毒性逆转。在RTA的接口Serial6/0上启用毒性逆转,请在如下的空格中补充完整的配置命令
[RTA-Serial6/0]rip poison-reverse
配置完成后,看到如下debugging信息:
*Oct 21 09:40:02:143 2008 RTA RM/6/RMDEBUG: RIP 1 : Sending response on interface Serial6/0 from 192.168.1.1 to 255.255.255.255
*Oct 21 09:40:02:143 2008 RTA RM/6/RMDEBUG:   Packet : vers 1, cmd response, length 44
*Oct 21 09:40:02:143 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.0.0, cost 1
*Oct 21 09:40:02:143 2008 RTA RM/6/RMDEBUG:     AFI 2, dest 192.168.2.0, cost 16
由以上输出信息可知,启用毒性逆转后,RTA在接口Serial 6/0上发送的路由更新包含了路由192.168.2.0,但度量值为16(无穷大)。相当于显式地告诉RTB,从RTA的接口Serial6/0上不能到达网络192.168.2.0。
配置接口工作在抑制状态
在前面实验中,路由器在所有接口都发送协议报文,包括连接PC的接口。实际上,PC并不需要接收RIP协议报文。我们可以在RIP视图下配置silent-interface命令使接口只接收而不发送RIP协议报文。
配置RTA接口GigabitEthernet 0/0工作在抑制状态,请补充完整的配置命令:
[RTA-rip-1]silent-interface GigabitEthernet 0/0
配置RTB接口GigabitEthernet 0/0工作在抑制状态,请补充完整的配置命令:
[RTB-rip-1]silent-interface GigabitEthernet 0/0
配置完成后,用debugging命令来观察RIP收发协议报文的情况。可以发现,RIP不再从接口GigabitEthernet0/0发送协议报文了。
这种方法的另外一个好处是防止路由泄漏而造成网络安全隐患。比如,公司某台运行RIP的路由器连接到公网,那就可以通过配置silent-interface而防止公司内网中的路由泄漏到公网上。
此步骤完成后,在路由器上关闭debugging,以免影响后续实验。
<RTA>undo debugging all
<RTB>undo debugging all
 楼主| 发表于 2013-8-10 15:52:23 | 显示全部楼层
配置RIPv2
本实验首先通过让RIPv1在划分子网的情况下不能正确学习路由,从而让学员了解到RIPv1的局限性;然后指导学员启用RIPv2协议。通过本实验,学员应该能够了解RIPv1的局限性,并掌握如何在路由器上配置RIPv2。
建立物理连接并运行超级终端
  将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
在PC和路由器配置IP地址
IP地址列表
设备名称        接口        IP地址        网关
RTA        S6/0        192.168.1.1/24        --
        G0/0        192.168.0.1/24        --
RTB        S6/0        192.168.1.2/24        --
        G0/0        10.0.0.1/24        --
PCA        --        192.168.0.2/24        192.168.0.1
PCB        --        10.0.0.2/24        10.0.0.1
按上表在路由器接口上以及PC上配置IP地址。
配置RIPV1,观察路由表
在RTA上创建RIPv1进程并在RTA的两个接口上使能RIP,具体命令为:
[RTA]rip
[RTA-rip-1]network 192.168.0.0
[RTA-rip-1]network 192.168.1.0
在RTB上创建RIPv1进程并在RTA的两个接口上使能RIP,具体命令为:
[RTB]rip
[RTB-rip-1]network 192.168.1.0
[RTB-rip-1]network 10.0.0.0
  配置完成后,在RTA上通过display ip routing-table命令查看全局路由表,从路由表输出信息可以看到,RTA路由表中通过RIP协议学习到的路由目的网段为10.0.0.0/8,该目的网段与实际RTB的网络不一致(一致/不一致),导致这种结果的原因是RIPv1协议报文中不携带掩码信息所致,路由信息以自然掩码学习.要解决该问题可以将RIP运行版本修改为RIPv2
配置RIPV2
在步骤三的基础上修改RTA、RTB的RIP版本为Version 2,在正确的视图下配置RIP Version 2的命令:
[RTA-rip-1]version 2
[RTB-rip-1]version 2
要使得RIP V2能够向外发布子网路由和主机路由,而不是按照自然掩码发布网段路由,还需要配置关闭RIPV2自动聚合功能,在正确视图下完成该配置的命令:
[RTA-rip-1]undo summary
[RTB-rip-1]undo summary     
配置完成后,在RTA上查看路由表,可以看到,RTA学习到的RIP路由的目的网段为10.0.0.0/24,此时如果路由表中仍然有路由10.0.0.0/8,其原因可能是RIP路由的老化时间是180秒。当未收到关于此路由的更新超过180秒后,RIP才会把此路由从IP路由表中撤销  
在RTA上通过命令display rip查看RIP运行状态,从其输出信息可知, 当前RIP的运行版本是RIPv2
配置RIPv2认证
在RTA上添加如下配置:
[RTA-Serial6/0]rip authentication-mode md5 rfc2453 aaaaa
如上配置命令的含义是在接口S6/0下启动RIPV2的MD5密文验证,验证密钥是aaaaa
并注定MD5认证报文使用RFC 2453标准的报文格式
配置RTB的S6/0启动RFC 2453格式的MD5认证,密钥为abcde,请在如下空格中填写完整的配置命令:
[RTB-Serial6/0]rip authentication-mode md5 rfc2453 abcde
因为原有的路由需要过一段时间才能老化,所以可以将接口关闭再启用,加快重新学习路由的过程。例如,关闭再启用RTA的接口Serial6/0,如下:
[RTA-Serial6/0]shutdown
[RTA-Serial6/0]undo shutdown
配置完成后,在路由器上查看路由表,在RTA的路由表中没有RIP路由,在RTB的路由表中也没有RIP路由可以看到,因认证密码不一致,RTA不能够学习到对端设备发来的路由
修改RTB的MD5认证密钥,使其与RTA认证密钥一致,请在如下空格中补充完整的配置命令:
[RTA-Serial6/0]rip authentication-mode md5 rfc2453 aaaaa
配置完成后,等待一段时间后,再查看RTA上的路由表,可以看到,RTA路由表中有了正确的路由10.0.0.0/24。请在如下空格中说明为什么需要等待一段时间后才能看到正确的路由:需要等到RIP的更新周期
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-9-19 16:31 , Processed in 0.140400 second(s), 19 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表