网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 2892|回复: 6

京东翰林教育集团 H3CTE讲师指导实验7PPP

[复制链接]
发表于 2013-8-3 16:52:54 | 显示全部楼层 |阅读模式
PPP
PPP协议基本配置
运行超级终端并初始化路由器配置
将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
依据规划建立两台路由器之间的物理连接
将两台路由器的S1/0接口通过V35电缆连接,然后在RTA上执行命令display interface serial1/0,根据其输出信息可以看到:
Serial1/0 current state:up Line protocol current state:up
Link layer protocol is:ppp
在RTB上执行同样的命令并查看如上信息
通过如上输出信息可以得知,路由器串口默认的链路层封装协议是ppp
配置路由器广域网接口IP地址
在RTA上配置广域网接口S1/0的IP地址。请补充完整的配置命令:
[RTA]interface Serial 1/0                                 
[RTA-Serial1/0]ip address 10.1.1.1 30或者ip address 10.1.1.1 255.255.255.252
在RTB上也完成广域网接口IP地址配置
在RTA的S1/0接口模式下,执行命令display this,可以看到:
interface Serial1/0
link-protocol ppp
ip address 10.1.1.2 255.255.255.252 ,根据此信息检查并核实配置的正确性。
在RTB的S1/0接口模式下,执行同样的命令并查看核实配置的正确性
在RTA路由器上执行命令display interface serial1/0,根据其输出信息可以看到:
Serial1/0 current state:up Line protocol current state:up
Link layer protocol is ppp
LCP opened, IPCP opened
检查路由器广域网之间的互通性
在RTA上通过ping命令检查RTA与RTB广域网之间的互通性,其结果是:可以互通
PPP PAP认证配置
在开始实验前,将路由器配置恢复到默认状态。
配置路由器广域网接口IP地址并确认互通性
依据本实验IP地址规划表,在RTA和RTB上配置广域网接口的IP地址
从实验任务一得知,MSR路由器广域网接口默认的链路层封装协议是ppp。因此只要在广域网接口配置正确的IP地址后,RTA与RTB的广域网接口之间是能ping通的
在RTA上配置以PAP方式验证对端RTB
RTA为主验证方验证RTB,那么首先要在系统视图下配置将对端RTB的用户名和密码加入本地用户列表并设置用户的服务类型,请在RTA上完成添加对端用户名rtb,密码pwdpwd到本地用户列表,在如下空格中填写完整的命令:
[RTA] local-user rtb
[RTA-luser-rtb] service-type ppp
[RTA-luser-rtb] password simple  pwdpwd
其次在接口视图下设置本地验证对端RTB的方式为PAP,请在如下空格中填写完整的命令:
[RTA- Serial1/0] ppp authentication-mode pap
查看接口状态并验证互通性
在RTA上执行命令display interface serial 1/0,根据输出信息可以看到:
Serial1/0 current state:up  Line protocol current state:down
Link layer protocol is ppp
LCP closed
  在RTA上ping  RTB广域网接口地址,其结果为 不通,返回Request time out
配置RTB为被验证方
在RTB上配置本地被对端RTA以PAP方式验证时发送的PAP用户名(rtb)和密码(pwdpwd),该配置需要在接口视图下完成,请在下面的空格中填写完整的命令:
[RTB- Serial1/0] ppp pap local-user rtb password simple pwdpwd
查看接口状态以及验证RTA与RTB的互通性
在RTA上执行命令display interface serial 1/0,根据输出信息可以看到:
Serial1/0 current state: up  Line protocol current state: up
Link layer protocol is ppp
LCP opened,IPCP opened
在RTB上完成同样的信息查看
在RTA上ping RTB广域网接口地址,结果是:可以互通
PPP CHAP认证配置
在开始实验前,将路由器配置恢复到默认状态。
配置路由器广域网接口IP地址并确认互通性
依据本实验IP地址规划表,在RTA和RTB上配置广域网接口的IP地址
从实验一得知,MSR路由器广域网接口默认的链路层封装协议是ppp。因此只要在广域网接口配置正确的IP地址后,RTA与RTB的广域网接口之间是能ping通的
在RTA上配置以CHAP方式验证对端RTB
RTA为主验证方验证RTB,那么在RTA上完成了如下配置:
[RTA] local-user rtb
[RTA-luser-user2] password simple pwdpwd
[RTA-luser-user2] service-type ppp
如上配置的含义是:将对端RTB的用户名和密码加入本地用户列表并设置用户的服务类型
其次在接口视图下设置本地验证对端RTB的方式为CHAP,请在如下空格中填写完整的命令:
[RTA-Serial1/0] ppp authentication-mode chap
查看接口状态并验证互通性
在RTA上执行命令display interface serial 1/0,根据输出信息可以看到:
Serial1/0 current state:up  Line protocol current state: down
Link layer protocol is ppp
LCP closed
在RTA上ping RTB广域网接口地址,其结果为 不通,返回  Request time out
配置RTB为被验证方
在RTB上配置如下命令:
[RTB-Serial1/0] ppp chap user rtb
该配置命令的含义是:配置本地用户名,该用户名是发送到对端惊醒CHAP验证使用的用户名
[RTB-Serial1/0] ppp chap password simple pwdpwd
该配置命令的含义是配置默认的CHAP密码,在进行CHAP验证的时候使用此密码
查看接口状态以及验证RTA与RTB的互通性
在RTA上执行命令display interface serial 1/0,根据输出信息可以看到:
Serial1/0 current state:up  Line protocol current state:up
Link layer protocol is ppp
LCP opened,IPCP opened
在RTB上完成同样的信息查看
在RTA上ping RTB广域网接口地址,结果是:可以互通
PPP MP配置
在开始实验前,将路由器配置恢复到默认状态。
依据要求,使用两对V.35电缆分别连接RTA和RTB
在RTA和RTB上创建Mp-group接口并配置IP地址
分别在RTA和RTB上创建Mp-group接口,并配置相应的IP地址。
在RTA上配置如下:
[RTA] interface mp-group 1
在该命令中,数字1的含义是表示MP-group接口的编号是1
[RTA-Mp-group1] ip address 10.1.1.1 30
在RTB上完成类似的配置,只是iP地址为10.1.1.2。
在RTA和RTB上将相应物理接口加入Mp-group接口
分别在RTA和RTB上将相应的物理接口加入到Mp-group接口中,并将相应的物理接口封装PPP协议。
在RTA上配置如下,请在空格处补全配置:
[RTA] interface serial 1/0
[RTA-Serial1/0] link-protocol ppp
[RTA-Serial1/0] ppp mp mp-group 1
[RTA] interface serial 2/0
[RTA-Serial2/0] link-protocol ppp
[RTA-Serial2/0] ppp mp mp-group 1
在RTB上完成如上同样的配置。
  验证并查看MP效果
在RTA上执行命令display ppp mp,根据其输出信息可以看到:
The member channels bundled are:_
Serial1/0                Up-Time:2009/06/10  08:07:14:496
Serial2/0                Up-Time:2009/06/10  08:07:14:497
在RTA上执行命令display interface Mp-group 1,根据其输出信息可以看到:
Mp-group1 current state: up  Line protocol current state: up
Link layer protocol is ppp
LCP opened, MP opened, IPCP opened
在RTA上ping RTB上的MP接口ip地址,其结果为:可以互通
 楼主| 发表于 2013-8-3 16:53:47 | 显示全部楼层
帧中继
帧中继物理接口静态映射互通配置
实验任务一中的PC以及路由器的IP地址规划如表8-1所示。
实验任务一IP地址规划
设备        接口        IP地址/掩码        本地DLCI
RTA        S1/0        10.1.1.1/24        30、40
RTB        S1/0        10.1.1.2/24        70
RTC        S1/0        10.1.1.3/24        80
运行超级终端并初始化路由器配置
  将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
依据规划,配置相关的IP地址
依据表8-1规划的IP地址,为路由器的接口配置IP地址。
配置广域网接口封装
在RTA上做如下配置:
[RTA-Serial1/0] link-protocol fr ietf,该命令的含义是封装接口的链路层协议为帧中继,命令中IETF的含义是选择IETF标准(ietf)格式进行帧中继封装
在RTB、RTC上完成同样的配置
配置RTA上帧中继相关参数
在RTA的Serial 1/0接口上配置如下:
[RTA-Serial1/0] fr interface-type dte  
该命令的含义是 配置帧中继接口类型是DTE   
[RTA-Serial1/0] fr lmi type Q933a   
该命令的含义是 配置帧中继接口的LMI协议类型为Q933a
[RTA-Serial1/0] fr map ip 10.1.1.2 30   
[RTA-Serial1/0] fr map ip 10.1.1.3 40   
请在空格处补充完整的配置并说明该配置命令的含义
配置帧中继的地址映射,其中IP地址是对端的IP地址,DLCI是本地虚电路号
[RTA-Serial1/0] ip address 10.1.1.1 24
配置RTB、RTC上帧中继相关参数
请在如下空格处补充完全RTB上帧中继相关的配置:
[RTB-Serial1/0] fr interface-type dte
[RTB-Serial1/0] fr lmi type Q933a  
[RTB-Serial1/0] fr map ip 10.1.1.1 70   
[RTB-Serial1/0] ip address 10.1.1.2 24
请在如下空格处填写完整的RTC上帧中继相关的配置:
[RTC-Serial1/0] fr interface-type dte  
[RTC-Serial1/0] fr lmi type Q933a     
[RTC-Serial1/0] fr map ip 10.1.1.1 80     
[RTC-Serial1/0] ip address 10.1.1.3 24
配置路由器模拟帧中继交换机
配置路由器FR-Switch实现帧中继交换机功能:
[fr switch]fr switching   //启用帧中继交换机功能

[fr switch]interface s6/0                  //连接RTA
[fr switch-Serial6/0]link-protocol fr
[fr switch-Serial6/0]fr interface-type dce
[fr switch-Serial6/0]fr dlci 30
[fr switch-fr-dlci-Serial6/0-30]quit
[fr switch-Serial6/0]fr dlci 40
[fr switch-fr-dlci-Serial6/0-40]quit

[fr switch]interface s5/0                  //连接RTB
[fr switch-Serial5/0]link-protocol fr
[fr switch-Serial5/0]fr interface-type dce
[fr switch-Serial5/0]fr dlci 70
[fr switch-fr-dlci-Serial5/0-70]quit

[fr switch]interface s5/1                  //连接RTC
[fr switch-Serial5/1]link-protocol fr
[fr switch-Serial5/1]fr interface-type dce
[fr switch-Serial5/1]fr dlci 80
[fr switch-fr-dlci-Serial5/0-80]quit

[fr switch]fr switch a-b interface Serial6/0 dlci 30 interface Serial5/0 dlci 70
[fr switch-fr-switching-a-b]quit
[fr switch]fr switch a-c interface Serial6/0 dlci 40 interface Serial5/1 dlci 80
[fr switch-fr-switching-a-c]quit

检测帧中继交换机配置是否成功:
<fr switch>display fr switch-table all
Total PVC switch records:2
PVC-Name                       Status   Interface(Dlci) <-----> Interface(Dlci)
a-b                            Active   Serial6/0(30)           Serial5/0(70)
a-c                            Active   Serial6/0(40)           Serial5/1(80)
发现两个通道都已经active,通道配置成功。
查看验证接口配置的正确性
在RTA上执行命令display fr map-info,根据该其输出信息可以看到:
DLCI = 30, IP 10.1.1.2, Serial1/0   status = active
DLCI = 40, IP 10.1.1.3, Serial1/0   status = active
在RTB、RTC上执行同样的命令查看相关信息
在RTA上执行命令display fr lmi-info,根据其输出信息可以看到:
out status enquiry = 243, in status = 243
30秒之后,在RTA上重复执行命令display fr lmi-info,根据其输出信息可以看到
out status enquiry数值 增加 (增加/减少),in status数值 增加(增加/减少)
在RTB、RTC上完成同样如上的操作
注意:
步骤八中out status enquiry显示的数值只作为参考,具体数值以实验室的执行命令display fr lmi-info后的显示值为准。
验证互通性
在RTA上ping RTB、RTC的S1/0接口IP地址,其结果是 可以互通
 楼主| 发表于 2013-8-3 16:57:29 | 显示全部楼层
帧中继子接口静态映射互通配置
实验任务二中的PC以及路由器的IP地址规划如表8-2所示。
实验任务二IP地址规划
设备        接口        IP地址/掩码        本地DLCI
RTA        S1/0.1        10.1.1.1/30        30
        S1/0.2        10.1.2.1/30        40
RTB        S1/0        10.1.1.2/30        70
RTC        S1/0        10.1.2.2/30        80
运行超级终端并初始化路由器配置
  将PC(或终端)的串口通过标准Console电缆与交换机的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
依据规划,配置相关的IP地址
依据表8-2规划的IP地址,为路由器的接口配置IP地址。
配置路由器上帧中继相关参数
实现帧中继协议的封装标准为IEF格式,帧中继接口的终端类型为DTE,接口的LMI类型为Q933a,请在RTA接口S1/0上完成满足如上要求的配置:
[RTA] interface serial 1/0
[RTA-Serial1/0] link-protocol fr ietf.
[RTA-Serial1/0] fr interface-type dte  
[RTA-Serial1/0] fr lmi type Q933a  
在RTB、RTC的接口S1/0上完成同样的配置
为RTA建立子接口,并配置子接口上的帧中继相关参数
在RTA上建立子接口,请在如下空格处补充完整的命令
[RTA]interface Serial 1/0.1 p2p
该命令中P2P的含义是定义帧中继点到点类型子接口
[RTA-Serial0/0.1]ip address 10.1.1.1 30
[RTA-Serial0/0.1]fr dlci 30
[RTA]interface Serial 1/0.2 p2p
[RTA-Serial0/0.1]ip address 10.1.2.1 30
[RTA-Serial0/0.1]fr dlci 40
配置RTB、RTC接口上的帧中继相关信息
在RTB上配置帧中继子接口,请补充空格中完整的命令:
interface Serial1/0.1 p2p
fr dlci  70
ip address 10.1.1.2 255.255.255.252
请在如下的空格中完成RTC上帧中继子接口的配置:
interface Serial 1/0.1 p2p
fr dlci 80
ip address 10.1.2.2 255.255.255.252
配置路由器模拟帧中继交换机
本步骤中FR-Switch的配置与实验任务一相同,保留其配置不变即可。
查看RTA子接口上的相关信息
在RTA上执行命令display fr map-info,根据该其输出信息可以看到:
DLCI 30, Point-to-Point DLCI, Serial1/0.1, status = active
DLCI 40, Point-to-Point DLCI, Serial1/0.2, status = active
在RTB、RTC上执行同样的命令查看相关信息
在RTA上执行命令display fr lmi-info,根据其输出信息可以看到:
out status enquiry = 451, in status = 451
30秒之后,在RTA上重复执行命令display fr lmi-info,根据其输出信息可以看到
out status enquiry数值 增加 (增加/减少),in status数值 增加(增加/减少)
在RTB、RTC上完成同样如上的操作
验证互通性
在RTA上ping RTB、RTC的S1/0.1接口IP地址,其结果是 可以互通  
 楼主| 发表于 2013-8-4 16:24:01 | 显示全部楼层
IP基础
基本的IP网段内通信
划分IP子网
本实验中给定的一个C类网段地址192.168.1.0.该地址段有8个地址位,一共有256个ip地址,其网络地址是192.168.1.0,广播地址是192.168.1.255,一共有254个可用主机地址
  现在要求将该网段地址划分子网实现每个网段内可用的主机地址数是25,请在下面的空格中写出最佳的子网划分结果(包括网段和掩码):
IP:192.168.1.0    掩码:255.255.255.224
IP:192.168.1.32   掩码:255.255.255.224
IP:192.168.1.64   掩码:255.255.255.224
IP:192.168.1.96   掩码:255.255.255.224
IP:192.168.1.128  掩码:255.255.255.224
IP:192.168.1.160  掩码:255.255.255.224
IP:192.168.1.192  掩码:255.255.255.224
IP:192.168.1.224  掩码:255.255.255.224
配置IP地址
在PCA上配置其IP地址为192.168.1.10/255.255.255.240,在RTA的G0/0接口上配置IP地址为192.168.1.19/255.255.255.240。
配置完成后,在PC的“命令提示符”窗口下,键入命令ipconfig来验证PC的IP地址是否配置正确,根据其输出信息回答下面的问题:
PCA的显示结果是:
IP Address192.168.1.10; Subnet  Mask 255.255.255.240;  
Default Gateway 空,没有
在RTA上通过display interface GigabitEthernet 0/0命令可以查看接口G0/0的信息,根据其输出信息可以看到Internet Address is192.168.1.19 Primary
验证相同IP网段内通信
在PCA上通过ping命令检测PCA与RTA之间的互通,其结果是不能ping通RTA的G0/0接口地址,ping结果返回信息Destination host unreachable
产生这种情况的原因是PCA与RTA G0/0接口直连但是PCA与RTA接口G0/0的IP地址不在一个网段,因此无法互通
在不修改PCA的IP地址以及掩码情况下,修改RTA的G0/0接口地址为:192.168.1.16/28,该地址中数字28的含义是掩码是28位,即255.255.255.240,在RTA的G0/0接口下不能成功的配置该IP地址,产生这种情况的原因是192.168.1.16/28是网络地址,不可用
要解决该问题,在不修改PCA的IP地址以及掩码的情况下,RTA的G0/0接口ip地址可以配置范围是192.168.1.1~192.168.1.9;192.168.1.11~192.168.1.14 掩码:255.255.255.240
配置网关
配置RTA上接口G0/1的ip地址为2.2.2.1/30,要确保PCB与G0/1能够互通,那么PCB的IP地址应该配置为 2.2.2.2/30
配置完成后,在PCA上ping RTA接口G0/1的地址2.2.2.1,其结果是无法互通
产生这种结果的原因是PCA上没有配置网关,不能通过网关实现跨网段路由
保持步骤二中配置的PCA的IP地址不变,配置RTA的G0/0接口的IP地址为192.168.1.1/28,那么要实现PCA可以和RTA接口G0/1互通,那么PCA的网关地址应该配置为 192.168.1.1
配置完成后,在PCA上ping RTA接口G0/1的地址2.2.2.1,其结果是可以互通
由此可以理解,PC上网关的含义是相当于一个中转器,所有发往与自己不同网段的IP数据包都会被发送给网关,由网关来完成数据包的下一步转发  
验证不同网段IP互通
完成步骤四后,在PCA上ping PCB,其结果是无法ping通
要解决该问题,需要给PCB配置网关地址2.2.2.1   
按照上述解决办法完成配置修改后,在PCA 上再次ping PCB,  其结果是可以ping通
 楼主| 发表于 2013-8-4 16:25:00 | 显示全部楼层
ARP
ARP表项观察
运行超级终端并初始化路由器配置
将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置PC及路由器的IP地址
IP地址列表
设备名称        接口        IP地址
PCA        --        172.16.0.1/24
PCB        --        172.16.1.1/24
RTA        G0/0        172.16.0.254/24
RTA        G0/1        172.16.1.254/24
据表10-1所示在PC上配置IP地址和掩码。配置完成后,在PC的“命令提示符”窗口下,键入命令ipconfig来验证PC的IP地址是否配置正确,根据其输出信息回答下面的问题:
PCA的显示结果是:
IP Address 172.16.0.1 ; Subnet  Mask 255.255.255.0 ;
Default Gateway  空
PCB的显示结果是:
IP Address 172.16.1.1 ; Subnet  Mask  255.255.255.0;
Default Gateway 空
然后在RTA的接口上配置IP地址及掩码,请在下面的空格中补充完整的命令:
[RTA]interface GigabitEthernet0/0
[RTA-GigabitEthernet0/0] ip address 172.16.0.254 24
[RTA]interface GigabitEthernet0/1
[RTA-GigabitEthernet0/1] ip address 172.16.1.254 24
查看ARP信息
在RTA上执行执行命令display interface GigabitEthernet 0/0,根据该命令的输出信息,填写如下空格:
Internet Address is 172.16.0.254/24 Primary
IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e2d1-bf50
在RTA上执行命令display interface GigabitEthernet 0/1,根据该命令的输出信息,填写如下空格:
Internet Address is 172.16.1.254/24 Primary
IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e2d1-bf51
在PC的“命令提示符”窗口下,键入命令ipconfig /all来查看PC的接口MAC与IP地址
根据该命令的输出信息,请填写如下空格PC的MAC地址
PCA: Physical Address. . . . . . . . . : 00-1C-23-3D-56-95
PCB: Physical Address. . . . . . . . . : 00-13-72-8E-47-51
根据以上信息,我们做一张表,表的内容是PC及RTA的IP地址与MAC地址对应关系,请补充表中空格处的MAC地址如下所示:
IP地址与MAC地址对应关系列表
设备名称        接口        IP地址        MAC地址
PCA        --        172.16.0.1/24        00-1C-23-3D-56-95
PCB        --        172.16.1.1/24        00-13-72-8E-47-51
RTA        G0/0        172.16.0.254/24        000f-e2d1-bf50
RTA        G0/1        172.16.1.254/24        000f-e2d1-bf51
然后,分别在PCA和PCB的“命令提示符”窗口下用ping命令来测试PC到RTA的可达性,以使PC及RTA建立ARP表项。
测试完成后,分别在PCA、PCB和RTA上查看ARP表项信息,分别在PCA和PCB的“命令提示符”窗口下用arp –a来查看ARP表象信息,根据该命令的输出信息,请填写如下的空格:
PCA的输出信息:
   Internet Address      Physical Address      Type
172.16.0.254           000f-e2d1-bf50      dynamic
PCB的输出信息:
   Internet Address      Physical Address      Type
172.16.1.254            000f-e2d1-bf51    dynamic
在RTA上可以在任何视图下执行display arp all命令查看路由器所有的ARP表项,请执行该命令并根据其输出信息补充如下的空格:
IP Address       MAC Address     VLAN ID  Interface   Aging  Type
172.16.0.1      001c-233d-5695    N/A       GE0/0      13     D
172.16.1.1      0013-728e-4751    N/A       GE0/1      15      D
如上输出信息中,type字段的含义是ARP表项类型:动态,用D表示;静态,用S表示;授权,用A表示;
Aging字段的含义是动态ARP表项的老化时间。
把我们所做的表1-2与PC及RTA上的ARP表项对比一下。可知,PC及RTA都建立了正确的ARP表项,表项中包含了IP地址和对应的MAC地址。
注意:
学员实验过程中所显示的MAC地址与本指导手册中的不同,是正常现象。
ARP代理配置
本实验通过在设备上配置ARP代理,使设备能够对不同子网间的ARP报文进行转发,使学员能够了解ARP代理的基本工作原理,掌握ARP代理的配置方法。
运行超级终端并初始化路由器配置
  将PC(或终端)的串口通过标准Console电缆与路由器的Console口连接。电缆的RJ-45头一端连接路由器的Console口;9针RS-232接口一端连接计算机的串行口。
  检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化。
配置PC及路由器的IP地址
IP地址列表
设备名称        接口        IP地址
PCA        --        172.16.0.1/16
PCB        --        172.16.1.1/16
RTA        G0/0        172.16.0.254/24
RTA        G0/1        172.16.1.254/24

根据上表所示在PC上配置IP地址和掩码。配置完成后,在PC的“命令提示符”窗口下,键入命令ipconfig来验证PC的IP地址是否配置正确。根据其输出信息回答下面的问题:
PCA的显示结果是:
IP Address172.16.0.1; Subnet  Mask  255.255.0.0;  
Default Gateway 空
PCB的显示结果是:
IP Address172.16.1.1; Subnet  Mask 255.255.0.0;  
Default Gateway 空
然后在RTA的接口上配置IP地址及掩码,请在下面的空格中补充完整的命令:
[RTA]interface GigabitEthernet0/0
[RTA-GigabitEthernet0/0] ip address 172.16.0.254 24
[RTA]interface GigabitEthernet0/1
[RTA-GigabitEthernet0/1] ip address 172.16.1.254 24
配置ARP代理
在PCA和PCB上通过ping来检测他们之间是否可达,检测的结果是不能互通
导致这种结果的原因是因为尽管PCA和PCB处于同一个子网内(掩码都是255.255.0.0),但RTA上两个接口的子网是不同的(分别为172.16.0.0/24和172.16.1.0/24),所以它不会在两个不同子网之间转发ARP报文
在RTA上配置ARP代理,请在下面的空格处补充完整的命令
[RTA]interface GigabitEthernet0/0
[RTA-GigabitEthernet0/0] proxy-arp enable
[RTA]interface GigabitEthernet0/1
[RTA-GigabitEthernet0/1] proxy-arp enable
配置完成后,在PCA上用ping命令测试到PCB得可达性,其结果是 可以互通
查看ARP信息
在PCA上查看ARP表项,根据其输出信息补充如下的空格
   Internet Address      Physical Address      Type
   172.16.1.1           000f-e2d1-bf50       dynamic
   ARP表项中PCB的IP地址对应的MAC地址与RTA接口G0/0的MAC地址相同,由此可以看出,是RTA的接口G0/0接口执行了ARP代理功能,为PCA发出的ARP请求提供了代理应答。
在PCB上查看ARP表项,可以看到 ARP表项中PCA的IP地址对应的MAC地址与RTA的接口G0/1的MAC地址相同
在RTA上通过可以通过display arp all命令查看ARP表项,其输出结果与实验一的结果一样     
 楼主| 发表于 2013-8-4 16:27:30 | 显示全部楼层
本帖最后由 jdhl 于 2013-8-4 16:31 编辑

DHCP
PCA直接通过RTA获得IP地址
建立物理连接并初始化路由器配置
  按实验组网图进行物理连接并检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
在设备上配置IP地址及路由
在如下空格中补充完整命令,配置RTA接口G0/0 IP地址为172.16.0.1/24
[RTA-GigabitEthernet0/0] ip address 172.16.0.1 24
交换机S3610采用出厂默认配置,不做任何配置,在这种情况下,交换机所有的端口都属于VLAN 1
配置RTA作为DHCP服务器
配置RTA为DHCP 服务器,给远端的PCA分配IP网段为172.16.0.0/24的地址。请补充下面空格中缺省的命令:
配置RTA:
[RTA] dhcp enable  启动DHCP服务
[RTA]dhcp server forbidden-ip 172.16.0.1
如上配置命令的含义是配置DHCP地址池中不参与自动分配的IP地址,也即,172.16.0.1不参与地址分配
[RTA]dhcp server ip-pool 1
如上命令中数值1的含义是:DHCP地址池名称,是地址池的唯一标识
[RTA-dhcp-pool-pool1]network 172.16.0.0  mask 255.255.255.0
[RTA-dhcp-pool-pool1]gateway-list  172.16.0.1
配置完成后,通过display current-configuration命令查看配置的正确性
PCA通过DHCP服务器获得IP地址
在Windows操作系统的“控制面板”中选择“网络和Internet连接”,选取“网络连接”中的“本地连接”,点击【属性】,在弹出的窗口中选择“Internet协议(TCP/IP)” ,点击【属性】,出现界面如下:


Internet协议(TCP/IP)属性
如图11-1所示,选中【自动获得IP地址】和【自动获得DNS服务器地址】并确定,以确保PCA配置为DHCP客户端。在PCA的“命令提示符”窗口下,键入命令ipconfig来验证PCA能否获得IP地址和网关等信息。其输出的显示结果是:
IP Address 172.16.0.2; Subnet  Mask 255.255.255.0;  
Default Gateway 172.16.0.1
如果无法获得IP,请检查线缆连接是否正确,然后在“命令提示符”窗口下用ipconfig /renew命令来使PCA重新发起DHCP请求。
查看DHCP服务器相关信息
在RTA上用display dhcp server forbidden-ip命令来查看DHCP服务器禁止分配的IP地址,执行该命令根据其输出信息可以看到172.16.0.1地址被服务器禁止分配。
在RTA上用display dhcp server free-ip来查看DHCP服务器可供分配的IP地址资源
在RTA上用display dhcp server ip-in-use all来查看DHCP地址池的地址绑定信息,执行该命令,根据其输出信息可以看到PCA的MAC地址绑定的IP地址为172.16.0.2
PCA通过DHCP中继方式获得IP地址
建立物理连接并初始化路由器配置
  按实验组网图进行物理连接并检查设备的软件版本及配置信息,确保各设备软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请学员在用户视图下擦除设备中的配置文件,然后重启设备以使系统采用缺省的配置参数进行初始化
在设备上配置IP地址及路由
设备IP地址列表
设备名称        物理接口        IP地址       
RTB        G0/0        172.16.1.1/24       
        G0/1        172.16.0.1/24       
RTA        G0/0        172.16.0.2/24       
按表11-1所示在路由器上配置IP地址。
在RTB上配置IP地址:
[RTB-GigabitEthernet0/0]ip address 172.16.1.1 24
[RTB-GigabitEthernet0/1]ip address 172.16.0.1 24
  在RTB上配置缺省路由,下一跳指向RTA:
[RTB]ip route-static 0.0.0.0 0 172.16.0.2
在RTA上配置接口IP及静态路由:
[RTA-GigabitEthernet0/0]ip address 172.16.0.2 24
[RTA]ip route-static 172.16.1.0 24 172.16.0.1
在RTA上配置DHCP服务器及在SWA上配置DHCP中继
配置RTA为DHCP 服务器,给远端的PCA分配IP网段为172.16.1.0/24的地址,在如下的空格中补充完整的配置命令:
[RTA] dhcp enable
[RTA]dhcp server forbidden-ip 172.16.1.1
[RTA]dhcp server ip-pool pool1
[RTA-dhcp-pool-pool1]network 172.16.1.0 mask 255.255.255.0
[RTA-dhcp-pool-pool1]gateway-list 172.16.1.1
配置RTB提供DHCP Relay服务,请在如下的空格中补充完整的配置命令
[RTB] dhcp enable  启动DHCP服务
[RTB]dhcp relay server-group 1 ip 172.16.0.2
如上命令中,数字1的含义是 DHCP服务器组号是1
[RTB]interface GigabitEthernet0/0
[RTB-GigabitEthernet0/0]dhcp select relay
[RTB-GigabitEthernet0/0]dhcp relay server-select 1
PCA通过DHCP中继获取IP地址
断开PCA与RTA之间的连接电缆,再接上,以使PCA重新发起DHCP请求。
完成重新获取地址后,在PCA的“命令提示符”窗口下,键入命令ipconfig来验证PCA能否获得IP地址和网关等信息,其输出信息显示为:
IP Address 172.16.1.2; Subnet  Mask 255.255.255.0;  
Default Gateway 172.16.1.1
查看DHCP中继相关信息
在RTA上通过命令display dhcp relay server-group 1查看DHCP中继服务器组的信息,
通过命令display dhcp relay interface GigabitEthernet0/0查看接口对应的DHCP中继服务器组信息
 楼主| 发表于 2013-8-5 15:24:44 | 显示全部楼层
IPv6基础
IPv6地址配置及查看
建立物理连接
按照拓扑进行连接,并检查路由器的软件版本及配置信息,确保路由器软件版本符合要求,所有配置为初始状态。如果配置不符合要求,请读者在用户模式下擦除设备中的配置文件,然后重启路由器以使系统采用缺省的配置参数进行初始化。
以上步骤可能会用到以下命令:
<RTA> display version
<RTA> reset saved-configuration
<RTA> reboot
配置接口自动生成链路本地地址及测试可达性,查看邻居信息
请在路由器RTA和RTB的系统视图下,使能路由器的IPv6报文转发功能,并在下面的空格中写出完整的命令。
   __ipv6_________
然后在路由器G0/0接口视图下,配置接口自动生成链路本地地址,并在下面的空格中写出完整的命令。
RTA上的命令:___[RTA-GigabitEthernet0/0]ipv6 address auto link-local_____
RTB上的命令:___[RTB-GigabitEthernet0/0]ipv6 address auto link-local_____
以上配置完成后,路由器会自动生成前缀为FE80::的链路本地地址。请用命令来查看生成的链路本地地址,并在下面的空格中写出完整的命令。
   ____display ipv6 interface GigabitEthernet 0/0_______________
请在下面填入所看到的地址。
RTA的接口G0/0链路本地地址是:_____ FE80::20F:E2FF:FED1:BDF8_____
RTB的接口G0/0链路本地地址是:_____ FE80::20F:E2FF:FED1:BFB8_____

说明:
链路本地地址和MAC地址相关,每台设备会有所不同。
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ______ ping ipv6 FE80::20F:E2FF:FED1:BFB8 -i GigabitEthernet 0/0___
可达性测试的结果是: 成功 □ 失败 □
如果可达性测试失败,请分析原因。
在RTA和RTB上通过命令来查看路由器的邻居信息,并在下面的空格中写出完整的命令。
   ______ display ipv6 neighbors all_________
RTA上看到的邻居地址信息是:_____ FE80::20F:E2FF:FED1:BFB8 _____
RTB的看到的邻居地址信息是:_____ FE80::20F:E2FF:FED1:BDF8_____
配置接口生成EUI-64地址并测试可达性,查看邻居信息
请在RTA及RTB的G0/0接口视图下,配置接口生成符合EUI-64格式的全球单播地址,并设定其前缀为1::/64。在下面的空格中写出完整的命令。
RTA上的命令:_________ ipv6 address 1::/64 eui-64_______
RTB上的命令:_________ ipv6 address 1::/64 eui-64__________
以上配置完成后,路由器接口会生成符合EUI-64规范的全球单播地址。用命令来查看生成的EUI-64地址并测试可达性。请在下面填入实验结果:
RTA的接口G0/0全球单播地址是:_________ 1::20F:E2FF:FED1:BDF8______
RTB的接口G0/0全球单播地址是:_________ 1::20F:E2FF:FED1:BFB8_______
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ________ping ipv6 1::20F:E2FF:FED1:BFB8__________
可达性测试的结果是: 成功 □ 失败 □
在RTA和RTB上通过命令来查看路由器的邻居信息。
RTA上看到的邻居地址信息是:
_1::20F:E2FF:FED1:BFB8,FE80::20F:E2FF:FED1:BFB8__
RTB的看到的邻居地址信息是:
_1::20F:E2FF:FED1:BDF8,FE80::20F:E2FF:FED1:BDF8__
配置接口生成全球单播地址并测试可达性,查看邻居信息
请在RTA及RTB的G0/0接口视图下,分别配置全球单播地址2::1/64及2::2/64,并在下面的空格中写出完整的命令。
RTA上的命令:____ [RTA-GigabitEthernet0/0]ipv6 address 2::1/64______
RTB上的命令:_____ [RTB-GigabitEthernet0/0]ipv6 address 2::2/64_____
以上配置完成后,路由器接口会生成全球单播地址。用命令display ipv6 interface g0/0 verbose来查看全球单播地址。请在下面填入实验结果:
RTA的接口G0/0全球单播地址是:________2::1/64_______________
RTB的接口G0/0全球单播地址是:________ 2::2/64______________
在RTA上用命令来进行RTA与RTB之间的IPv6可达性测试,并在下面的空格中写出完整的命令。
   ________<RTA>ping ipv6 2::2_______________
可达性测试的结果是: 成功 □ 失败 □
在RTA和RTB上通过命令来查看路由器的邻居信息。
RTA上看到的邻居地址信息是:______1::20F:E2FF:FED1:BFB8,FE80::20F:E2FF:FED1:BFB8,2::2____
RTB的看到的邻居地址信息是:___1::20F:E2FF:FED1:BDF8,FE80::20F:E2FF:FED1:BDF8,2::1____
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-13 12:11 , Processed in 0.140400 second(s), 21 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表