网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 2578|回复: 0

配置PE和CE之间运行OSPF路由协议

[复制链接]
发表于 2007-8-27 21:54:36 | 显示全部楼层 |阅读模式
有的客户使用OSPF作为路由协议在他们的VPN内运行,有时候在某些站点甚至结合RIP和BGP同时使用。本实验中,你将铺设OSPF作为在客户的VPN内部运行的路由协议。你需要完成以下的工作以达到这个目标:把OSPF作为PE和CE路由器之间的路由协议激活;在客户站点之间传输OSPF路由;配置到额外的运行RIP路由协议的客户路由器的连通。在铺设OSPF的过程中,你将面对几个问题:结合OSPF和其他路由协议共同工作(例如,RIP);重叠的OSPF区域号码;注入PE路由器以后而造成的不连续的OSPF骨干区域(Area 0)。

一些背景信息:
原来的客户网络包括OSPF area0(骨干区域)和OSPF area3,同时有附加的不运行OSPF而运行RIP路由协议的路由器;RIP路由通过重分布进入OSPF,见下图:

      随着客户从原来的帧中继网络向MPLS/VPN网络过渡,服务提供商把PE和CE之间的路由协议改为RIP,见下图:

      鉴于RIP作为路由协议的局限性,客户希望重新改为使用OSPF所谓路由协议。然而,由于MPLS/VPN在CE路由器之间加入了PE路由器,骨干区域和area3不在是一个连续的区域,这正是其中一个我们需要解决的问题,见下图:

以下是实验过程中可能使用到的命令:
address-family ipv4 vrf name ----- 选择在路由协议内为每个VRF进程配置
address-family vpnv4 ----- 选择VPNv4地址族配置
ip vrf forwarding name ----- 把一个接口绑定到某个VRF上面
ip vrf name ----- 创建一个虚拟路由/转发表(VRF)
ping vrf name host ----- 通过查询某个VRF检验主机的可达性
rd value ----- 为VRF分配路由区分符(RD)
address-family ipv4 vrf name ----- 选择在路由协议内为每个VRF进程配置
address-family vpnv4 ----- 选择VPNv4地址族配置
ip vrf forwarding name ----- 把一个接口绑定到某个VRF上面
ip vrf name ----- 创建一个虚拟路由/转发表(VRF)
neighbor ip-address activate ----- 为指定的邻居激活在地址族下交换路由
neighbor ip-address routere-flector-client ----- 在路由反射器上配置一个路由反射器客户
ping vrf name host ----- 通过查询某个VRF检验主机的可达性
rd value ----- 为VRF分配路由区分符(RD)
redistribute bgp as-number subnets ----- 重分布BGP路由;包括子网路由,到OSPF内
router ospf process vrf name ----- 在制定的VRF内启动OSPF
router bgp as-number ----- 选择BGP配置
route-target import|export value ----- 给一个VRF分配一个路由目标(Route Target)
show ip ospf database ----- 显示OSPF数据库
show ip bgp vpnv4 vrf name ----- 显示某个指定邻居的VPNv4路由
show ip route vrf name ----- 显示某个特定VRF的IP路由表
show ip vrf detail ----- 显示VRF的详细内容
telnet host /vrf name  ----- Telnet到与特定VRF直连的CE路由器上

实战一:在CE路由器上配置OSPF
        关闭RIP,A1 A2 A3 A4路由器上面使用router ospf process命令配置OSPF。根据背景信息里面的图划分OSPF区域
实战二:在PE路由器上配置OSPF
        在PE1 PE2 PE3 PE4使用router ospf vrf命令在VRF内配置OSPF,在相应的PE-CE链路上使用合适的area号码
        在VRF地址族中使用redistribut ospf命令把OSPF路由重分布入多协议BGP
        在OSPF路由器上,使用redistribute bgp subnets命令将多协议BGP的路由重分布入OSPF
        在OSPF路由器上配置RIP到OSPF的重分布,保证在A1上能够收到来自A5的RIP路由

检验——
        在A1到A4和PE1到PE4上使用show ip ospf neighbor命令检验OSPF邻接关系

PE3#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
203.1.2.1         1   FULL/  -        00:00:39    150.1.31.10     Serial0/0.4
203.1.3.1         1   FULL/  -        00:00:39    150.1.31.14     Serial0/0.3

        在A2上检查OSPF拓扑数据库。你应该看到Link States (resulting from OSPF connectivity between the PE and the CE router);Summary link states (OSPF routes originated by other OSPF CE routers) 以及 Type-5 External Link States (all other VPN routes originated in RIP)。注意,在同一个OSPF区域产生但连接到不同的PE路由器上的子网 (如下图的203.1.0.1子网)将以Summary Link States出现, 而不是作为Router 或者Network Link States

A2#show ip ospf database

            OSPF Router with ID (203.1.2.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
150.1.31.5      150.1.31.5      199         0x80000003 0xB430   2
150.1.31.13     150.1.31.13     196         0x80000003 0xC408   2
203.1.2.1       203.1.2.1       317         0x80000003 0xC36F   6

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
150.1.31.0      150.1.31.5      199         0x80000001 0xA6A5  
150.1.31.0      150.1.31.13     196         0x80000001 0x76CD  
150.1.31.12     150.1.31.13     307         0x80000001 0xFD7B  
150.1.31.16     150.1.31.5      174         0x80000001 0x636   
150.1.31.16     150.1.31.13     193         0x80000001 0xD55E  
203.1.0.1       150.1.31.5      129         0x80000001 0xD31E  
203.1.0.1       150.1.31.13     129         0x80000001 0xA346  
203.1.0.3       150.1.31.13     297         0x80000001 0x1751  
203.1.0.4       150.1.31.5      174         0x80000001 0xB539  
203.1.0.4       150.1.31.13     191         0x80000001 0x8561  
203.1.1.1       150.1.31.5      130         0x80000001 0xC828  
203.1.1.1       150.1.31.13     131         0x80000001 0x9850  
203.1.3.1       150.1.31.13     299         0x80000001 0xA5D   
203.1.4.1       150.1.31.5      176         0x80000001 0xA746  
203.1.4.1       150.1.31.13     191         0x80000001 0x776E  

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
150.1.31.128    150.1.31.5      201         0x80000001 0x31BE   3489660931
150.1.31.128    150.1.31.13     198         0x80000001 0x1E6    3489660931
203.1.127.3     150.1.31.5      201         0x80000001 0x5282   3489660931
203.1.127.3     150.1.31.13     198         0x80000001 0x22AA   3489660931
203.1.134.0     150.1.31.5      201         0x80000001 0x23AD   3489660931
203.1.134.0     150.1.31.13     198         0x80000001 0xF2D5   3489660931

        在CE路由器上面使用show ip ospf database type prefix命令检验单独的LSA,注意被设置了down bit
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-14 06:45 , Processed in 0.093600 second(s), 22 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表