网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 3027|回复: 0

高级域间(Inter-AS)MPLS/VPN设计

[复制链接]
发表于 2007-8-27 21:48:08 | 显示全部楼层 |阅读模式
高级域间(Inter-AS)MPLS/VPN设计
时间:240分钟
我们将在下面的实验拓扑中设计高级域间MPLS/VPN:

本实验,你需要基于下图对你的域间MPLS/VPN服务设计进行优化。初始化的设计(见下图),在两个ASBR之间使用一个EBGP对话,结果,由于他们同时需要储存所有的VPNv4路由并且重新为所有的VPNv4路由分配标签,因此造成这两台路由器内存利用的高度负担。

图一:Original Inter-AS MPLS VPN design
优化MPLS/VPN路由传播
在第一步提高域间MPLS VPN设计中,EBGP会话将在MPLS/VPN骨干两个MP-BGP路由反射器之间建立,见下图。这个设计优化了ASBR路由器的内存利用,减轻了内存负担,它们不再需要储存MP-BGP路由,甚至可以变为纯粹的P路由器。但是,此时的网络流量却不是最优化的,因为多有跨越AS的流量都必须经过路由反射器。

图二:Improved Inter-AS MPLS VPN design with no MPLS VPN on ASBR-routers

为了实现域间优化设计,你需要在两个AS内的路由反射器之间建立一条连续的标签交换路径(LSP)。你可能有好几种方案来实现这个目的,但是最直接简单的,无非把本地路由器loopback接口的IP地址重分布到另外一个AS的IGP路由内——
        在ASBR路由器上把支撑MPLS/VPN功能的路由器的Loopback接口的IP地址从OSPF(域内路由协议)重分布到BGP里面去;
        特别需要警惕的是必须保证OSPF到BGP重分布的路由必须指向外部的BGP邻居通告,而不会向出于相同的AS内部的BGP路由器发送;
        通告给外部BGP邻居的loopback地址被设置no-advertise属性,保证不被传发到远程AS的其他BGP路由器上面去;
        接收路由的ASBR路由器把所有设置了no-advertise属性的BGP前缀重分布到本地的IGP路由内,让远程loopback地址能够在本地IGP中可达,从而符合通过LDP分配标签的条件;

图三:IP routing needed to support improved Inter-AS MPLS VPN design
建立END-TO-END的LSP
自治系统之间配置的IP路由,在各个自治系统内建立连接到远程PE路由器的loopback接口地址的LSP。但是,由于LSP没有穿过AS之间的链路(ASBR之间没有进行标签交换,使用的是传统的三层路由转发),造成了损坏的LSP以及MPLS/VPN连接的不连续性。为了建立在MPLS/VPN的路由反射器之间的END-TO-END LSP,通过TDP或者LDP在每个自治系统内部建立起来的LSPs,必须通过在BGP会话中交换标签从而被缝合起来。

图四:Establishing end-to-end LSP by combining LDP-established LSP with
labels exchanged via BGP
优化MPLS/VPN数据流量
和之前的设计相似,优化性的域间MPLS/VPN设计是基于在MPLS/VPN里面的MP-BGP路由反射器之间建立EBGP会话的。另外,它通过使用CISCO IOS一个新的特征集,修改了BGP下一跳进程的规则——让MP-BGP下一跳地址经过MP-EBGP会话以后保持不变。由于BGP的下一跳一直保持是最后的入口PE路由器,那么域间的数据流量将被优化,间下图:

图五:Optimal Inter-AS MPLS VPN design
初始化配置:
PE-L#wr t
Building configuration...

Current configuration : 2677 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE-L
!
boot system ftp rlab/c2600-j1s3-mz.122-13.T1.bin 10.178.128.11
!
ip subnet-zero
!
!
ip tcp synwait-time 5
no ip domain lookup
ip host A1 203.1.131.1
ip host A2 203.1.132.1
ip host A3 203.1.133.1
ip host A4 203.1.134.1
ip host RR-2 192.168.31.1
ip host ASBR-R 192.168.31.2
ip host PE-R 192.168.31.3
ip host RR-1 192.168.32.1
ip host ASBR-L 192.168.32.2
ip host PE-L 192.168.32.3
!
ip vrf VPNA
rd 32:1
route-target export 32:1
route-target import 32:1
route-target import 31:1
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 192.168.32.3 255.255.255.255
!
interface FastEthernet0/0
description *** exercise interface ***
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.720
description *** WARNING! This interface is needed to load IOS. Do not change or remove it! ***
encapsulation dot1Q 720
ip address 10.178.11.20 255.255.0.0
!
interface Serial0/0
bandwidth 64
no ip address
encapsulation frame-relay
no fair-queue
!
interface Serial0/0.140 point-to-point
description *** Link to ASBR-L ***
ip unnumbered Loopback0
tag-switching ip
frame-relay interface-dlci 140   
!
interface Serial0/0.143 point-to-point
description *** Link to RR-1 ***
ip unnumbered Loopback0
tag-switching ip
frame-relay interface-dlci 143
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-15 18:29 , Processed in 0.078000 second(s), 22 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表