网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 1632|回复: 0

[VPN技术] IPSec site-PIX-site

[复制链接]
发表于 2007-8-27 17:13:02 | 显示全部楼层 |阅读模式

Lab Target: Site-to-Site between R4 and R5 Lo0 over PIX

hostname r4

crypto isakmp policy 10
hash md5
authentication pre-share
group 2
crypto isakmp key cisco address 45.1.1.5
!
!
crypto ipsec transform-set test esp-aes esp-md5-hmac
!
crypto map test 10 ipsec-isakmp
set peer 45.1.1.5
set transform-set test
match address 100

interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 47.1.1.4 255.255.255.0
half-duplex
crypto map test

ip route 20.1.1.0 255.255.255.0 47.1.1.7
ip route 45.1.1.0 255.255.255.0 47.1.1.7
!

access-list 100 permit ip 10.1.1.0 0.0.0.255 20.1.1.0 0.0.0.255
!
----------------------------------------------
hostname r5

crypto isakmp policy 10
hash md5
authentication pre-share
group 2
crypto isakmp key cisco address 45.1.1.10
!
!
crypto ipsec transform-set test esp-aes esp-md5-hmac
!
crypto map test 1 ipsec-isakmp
set peer 45.1.1.10
set transform-set test
match address 100
!
!
!
!
interface Loopback0
ip address 20.1.1.1 255.255.255.0
!
interface Ethernet1/0
ip address 45.1.1.5 255.255.255.0
half-duplex
crypto map test

access-list 100 permit ip 20.1.1.0 0.0.0.255 10.1.1.0 0.0.0.255
------------------------------------------
hostname pix
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0
nameif outside
security-level 0
ip address 45.1.1.7 255.255.255.0
!
interface Ethernet1
nameif inside
security-level 100
ip address 47.1.1.7 255.255.255.0

passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
access-list test extended permit udp host 45.1.1.5 host 45.1.1.10 eq isakmp
access-list test extended permit esp host 45.1.1.5 host 45.1.1.10
access-list test extended permit udp host 45.1.1.5 host 45.1.1.10 eq 4500

static (inside,outside) 45.1.1.10 47.1.1.4 netmask 255.255.255.255
access-group test in interface outside
route outside 20.1.1.0 255.255.255.0 45.1.1.5 1
route inside 10.1.1.0 255.255.255.0 47.1.1.4  1
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-16 10:38 , Processed in 0.078000 second(s), 20 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表