网管程序员论坛

 找回密码
 注册

QQ登录

只需一步,快速开始

查看: 1395|回复: 0

MPLS VPN Over TE Tunnels

[复制链接]
发表于 2007-8-27 13:46:06 | 显示全部楼层 |阅读模式
无Te Tunnel 的 初始化VPN
  PE1:
  hostname PE1
  ip cef
  !
  ip vrf aqua
  rd 100:1
  route-target export 1:1
  route-target import 1:1
  !
  mpls traffic-eng tunnels
  !
  interface Loopback0
  ip address 10.2.2.2 255.255.255.255
  no ip directed-broadcast
  !
  interface Ethernet2/0/1
  ip vrf forwarding aqua
  ip address 172.16.1.2 255.255.255.0
  !
  interface Ethernet2/0/2
  ip address 10.7.7.2 255.255.255.0
  ip router isis
  mpls traffic-eng tunnels
  tag-switching ip
  !
  router isis
  passive-interface Loopback0
  net 47.1234.2222.2222.2222.00
  is-type level-1
  metric-style wide
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
  !
  router bgp 1
  bgp log-neighbor-changes
  neighbor 10.11.11.11 remote-as 1
  neighbor 10.11.11.11 update-source Loopback0
  !
  address-family vpnv4
  neighbor 10.11.11.11 activate
  neighbor 10.11.11.11 send-community extended
  exit-address-family
  !
  address-family ipv4
  neighbor 10.11.11.11 activate
  no auto-summary
  no synchronization
  exit-address-family
  !
  address-family ipv4 vrf aqua
  redistribute connected
  no auto-summary
  no synchronization
  exit-address-family
  
  
  PE2:
  hostname PE2
  !
  ip vrf aqua
  rd 100:1
  route-target export 1:1
  route-target import 1:1
  !
  mpls traffic-eng tunnels
  !
  interface Loopback0
  ip address 10.11.11.11 255.255.255.255
  !
  interface POS0/1
  ip address 10.12.12.10 255.255.255.0
  ip router isis
  mpls traffic-eng tunnels
  tag-switching ip
  crc 16
  clock source internal
  !
  interface POS5/1
  ip vrf forwarding aqua
  ip address 172.16.13.11 255.255.255.0
  crc 32
  clock source internal
  !
  router isis
  passive-interface Loopback0
  mpls traffic-eng router-id Loopback0
  mpls traffic-eng level-1
  net 47.1234.1010.1010.1010.00
  is-type level-1
  metric-style wide
  !
  router bgp 1
  bgp log-neighbor-changes
  neighbor 10.2.2.2 remote-as 1
  neighbor 10.2.2.2 update-source Loopback0
  no auto-summary
  !
  address-family vpnv4
  neighbor 10.2.2.2 activate
  neighbor 10.2.2.2 send-community extended
  exit-address-family
  !
  address-family ipv4 vrf aqua
  redistribute connected
  no auto-summary
  no synchronization
  exit-address-family
  !
  
  PE1 到 PE2 做TE Tunnel
  
  PE1
  
  PE1#show run interface tunnel 0
  !
  interface Tunnel0
  ip unnumbered Loopback0
  no ip directed-broadcast
  no ip route-cache distributed
  tunnel destination 10.11.11.11
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng path-option 10 dynamic
  end
  
  PE1 到 P2 做TE Tunnel
  PE1#show run interface tunnel0
  !
  interface Tunnel0
  ip unnumbered Loopback0
  no ip directed-broadcast
  no ip route-cache distributed
  tunnel destination 10.5.5.5
  tunnel mode mpls traffic-eng
  tunnel mpls traffic-eng autoroute announce
  tunnel mpls traffic-eng path-option 10 dynamic
  end
您需要登录后才可以回帖 登录 | 注册

本版积分规则

QQ|小黑屋|手机版|Archiver|最新更新|网管程序员社区 鄂ICP备11008024号-3

GMT+8, 2019-11-14 19:17 , Processed in 0.078000 second(s), 20 queries .

Powered by 网管论坛

© 2001-2018 www.027safe.com Inc.

快速回复 返回顶部 返回列表